Re: [PATCH 6/9] builtin-init-db.c: use parse_options()
- From
- Olivier Marin <dkr+ml.git@free.fr>
- Date
- Jul 25, 2008, 15:20 UTC
- Message-ID
- <4889EF3A.6040605@free.fr>
- In-Reply-To
- <alpine.DEB.1.00.0807241801030.8986@racer>
Johannes Schindelin a écrit :
Show 5 quoted lines
>> >>> + OPT_BOOLEAN(0, "bare", &bare, "set up a bare repo"), >> s/set up/setup/ > > No. "setup" is a noun.
Right, sorry.
> We rely on shared_repository == 0 for non-shared repositories _almost > everywhere_.
I think we rely on the fact that PERM_UMASK == 0 and not on the value of shared_repository. Not the same thing.
That said, perhaps you are right: it is harmless.
Show 10 quoted lines
>>> + OPT_BIT('q', "quiet", &flags, "be quiet", INIT_DB_QUIET),
>> OPT__QUIET(&quiet),
>>
>> if (quiet)
>> flags |= INIT_DB_QUIET;
>>
>> to use the same quiet option everywhere?
>
> Why? Doesn't make it more readable, I think. I'd rather have 3 lines
> less.Hum.
Olivier.