Re: [PATCH/RFC v3 10/16] Create a note for every imported commit containing svn metadata.
- From
Florian Achleitner <florian.achleitner2.6.31@gmail.com>
- Date
- Aug 15, 2012, 20:10 UTC
- Message-ID
- <3474533.sTggvtNqe8@flomedio>
- In-Reply-To
- <7v1uj85427.fsf@alter.siamese.dyndns.org>
On Wednesday 15 August 2012 12:49:04 Junio C Hamano wrote:
Show 36 quoted lines
> Florian Achleitner <florian.achleitner.2.6.31@gmail.com> writes: > > To provide metadata from svn dumps for further processing, e.g. > > branch detection, attach a note to each imported commit that > > stores additional information. > > The notes are currently hard-coded in refs/notes/svn/revs. > > Currently the following lines from the svn dump are directly > > accumulated in the note. This can be refined on purpose, of course. > > - "Revision-number" > > - "Node-path" > > - "Node-kind" > > - "Node-action" > > - "Node-copyfrom-path" > > - "Node-copyfrom-rev" > > > > Signed-off-by: Florian Achleitner <florian.achleitner.2.6.31@gmail.com> > > --- > > > > vcs-svn/fast_export.c | 13 +++++++++++++ > > vcs-svn/fast_export.h | 2 ++ > > vcs-svn/svndump.c | 21 +++++++++++++++++++-- > > 3 files changed, 34 insertions(+), 2 deletions(-) > > > > diff --git a/vcs-svn/fast_export.c b/vcs-svn/fast_export.c > > index 1ecae4b..796dd1a 100644 > > --- a/vcs-svn/fast_export.c > > +++ b/vcs-svn/fast_export.c > > @@ -12,6 +12,7 @@ > > > > #include "svndiff.h" > > #include "sliding_window.h" > > #include "line_buffer.h" > > > > +#include "cache.h" > > Shouldn't it be near the beginning? Also if you include "cache.h", > it probably makes git-compat-util and strbuf redundant.
Ack.
Show 20 quoted lines
>
> > #define MAX_GITSVN_LINE_LEN 4096
> >
> > @@ -68,6 +69,18 @@ void fast_export_modify(const char *path, uint32_t
> > mode, const char *dataref)>
> > putchar('\n');
> >
> > }
> >
> > +void fast_export_begin_note(uint32_t revision, const char *author,
> > + const char *log, unsigned long timestamp)
> > +{
> > + timestamp = 1341914616;
>
> The magic number needs some comment.
>
> > + size_t loglen = strlen(log);
>
> decl-after-statement. I am starting to suspect that the assignment
> is a leftover from an earlier debugging effort, though.Oh yes sorry. Leftover from a previous experiment. Thx for your reviews Junio, I got too blind to see this.