Re: [PATCH v6 0/4] stash: Convert some `git stash` commands to a builtin
- From
Paul-Sebastian Ungureanu <ungureanupaulsebastian@gmail.com>
- Date
- Jun 28, 2018, 23:14 UTC
- Message-ID
- <2882d57b-2e98-b3f6-6f85-4e6f8c6feca6@gmail.com>
- In-Reply-To
- <nycvar.QRO.7.76.6.1806270011441.21419@tvgsbejvaqbjf.bet>
Hello,
On 27.06.2018 01:12, Johannes Schindelin wrote:
Show 8 quoted lines
>> Joel Teichroeb (4): >> stash: convert apply to builtin >> stash: convert drop and clear to builtin >> stash: convert branch to builtin >> stash: convert pop to builtin > > Were there any changes since v5 in these patches? >
There are some changes since v5 based on the reviews.
There are also some changes which were not suggested in the reviews, but which I considered to be good (I hope they really are). For example, in the previous version of the patch that introduces the `stash--helper`, there was no `assert_stash_like()` function (it was part of `get_stash_info()`). In v6, it was implemented as a separate function in order to keep it more alike to `git-stash.sh` script. Another difference was to change `assert_stash_ref()` function type from `int` to `void` and call `exit()` inside. This was introduced in order to make it more similar with `assert()` from `assert.h`. I do not think of these changes to be something of great importance, but I hope they might make the code easier to read.
Best, Paul