Re: [RFC PATCH v1 1/1] docs: add the new commit-msg tags 'Reported:' and 'Reviewed:'
- From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
- Date
- Nov 26, 2021, 12:49 UTC
- Message-ID
- <211126.86h7bzhyfy.gmgdl@evledraar.gmail.com>
- In-Reply-To
- <xmqq4k825o6r.fsf@gitster.g>
On Tue, Nov 23 2021, Junio C Hamano wrote:
Show 19 quoted lines
> Eric Wong <e@80x24.org> writes:
>
>> git send-email's capitalization does annoy me and I've looked
>> into changing it; but there's a bunch of tests and probably
>> dependent code that also need to be updated...
> [...]
> diff --git i/git-send-email.perl w/git-send-email.perl
> index 5262d88ee3..a61134c7d3 100755
> --- i/git-send-email.perl
> +++ w/git-send-email.perl
> @@ -1494,7 +1494,7 @@ sub send_message {
> To: $to${ccline}
> Subject: $subject
> Date: $date
> -Message-Id: $message_id
> +Message-ID: $message_id
> ";
> if ($use_xmailer) {
> $header .= "X-Mailer: git-send-email $gitversion\n";Perhaps one way to split this & make it more readable is to split this, i.e. the mesage-id's send-email itself generates & tests, usually it passes along format-patch's.
Show 9 quoted lines
> @@ -1789,7 +1789,7 @@ sub process_file {
> $has_mime_version = 1;
> push @xh, $_;
> }
> - elsif (/^Message-Id: (.*)/i) {
> + elsif (/^Message-ID: (.*)/i) {
> $message_id = $1;
> }
> elsif (/^Content-Transfer-Encoding: (.*)/i) {Not strictly needed due to the /i, maybe splitting out cosmetic changes would be better?
I also notice we have various hits for "git grep message-id", including regex checks you didn't update here.