Re: [PATCH 3/8] builtin/repack.c: extract redundant pack cleanup for --geometric
- From
Jeff King <peff@peff.net>
- Date
- Sep 7, 2023, 08:00 UTC
- Message-ID
- <20230907080026.GC1260718@coredump.intra.peff.net>
- In-Reply-To
- <5c25ef87c1430e012a2e48b738b3b5aa760b4b0f.1693946195.git.me@ttaylorr.com>
On Tue, Sep 05, 2023 at 04:36:46PM -0400, Taylor Blau wrote:
> To reduce the complexity of the already quite-long `cmd_repack()` > implementation, extract out the parts responsible for deleting redundant > packs from a geometric repack out into its own sub-routine.
Makes sense. Again, I'm happy to see some of these large functional pieces of cmd_repack() moved into sub-functions. Even if we never call them twice, IMHO it is a readability improvement to give them meaningful names.
-Peff