[PATCH v2 3/5] run-command: add braces for "if" block in wait_or_whine()
- From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
- Date
- Feb 2, 2021, 01:59 UTC
- Message-ID
- <20210202020001.31601-4-avarab@gmail.com>
- In-Reply-To
- <20210201144921.8664-1-avarab@gmail.com>
Add braces to an "if" block in the wait_or_whine() function. This isn't needed now, but will make a subsequent commit easier to read.
Signed-off-by: Ævar Arnfjörð Bjarmason <avarab@gmail.com> --- run-command.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/run-command.c b/run-command.c index ea4d0fb4b15..00e68f37aba 100644 --- a/run-command.c +++ b/run-command.c @@ -551,8 +551,9 @@ static int wait_or_whine(pid_t pid, const char *argv0, int in_signal) while ((waiting = waitpid(pid, &status, 0)) < 0 && errno == EINTR) ; /* nothing */ - if (in_signal) + if (in_signal) { return 0; + } if (waiting < 0) { failed_errno = errno;
-- 2.30.0.284.gd98b1dd5eaa7