Re: [PATCH 1/3] color.c: Refactor color_output to use enums
- From
Jeff King <peff@peff.net>
- Date
- Jan 15, 2020, 22:33 UTC
- Message-ID
- <20200115223309.GA4117117@coredump.intra.peff.net>
- In-Reply-To
- <20200110150547.221314-1-shawarmakarma@gmail.com>
On Fri, Jan 10, 2020 at 10:05:45AM -0500, Eyal Soha wrote:
> Signed-off-by: Eyal Soha <shawarmakarma@gmail.com> > --- > color.c | 28 +++++++++++++++++----------- > 1 file changed, 17 insertions(+), 11 deletions(-)
The patch itself looks good, but it would be nice to have a commit message explaining what's going on and why. Maybe something like:
Using an enum reduces the number of magic numbers in the code. Note that we also use values that allow easier computations. For example, colors with type COLOR_ANSI now store the actual foreground code we expect (e.g., red=31) instead of an offset into our array, and we can switch between foreground/background for all types by adding an offset. That will help when we add new color types in a future patch.
Show 14 quoted lines
> @@ -280,13 +286,13 @@ int color_parse_mem(const char *value, int value_len, char *dst)
> if (sep++)
> OUT(';');
> /* foreground colors are all in the 3x range */
> - dst = color_output(dst, end - dst, &fg, '3');
> + dst = color_output(dst, end - dst, &fg, 0);
> }
> if (!color_empty(&bg)) {
> if (sep++)
> OUT(';');
> /* background colors are all in the 4x range */
> - dst = color_output(dst, end - dst, &bg, '4');
> + dst = color_output(dst, end - dst, &bg, COLOR_BACKGROUND_OFFSET);
> }Your original dropped the comments here, since we're not saying "3" or "4" literally anymore. I could go either way, but I think I slightly preferred dropping them. It might be even nicer if we had COLOR_FOREGROUND_OFFSET = 0, which you could use instead of the bare "0".
-Peff