[PATCH v4 0/5] am/rebase: share read_author_script()
- From
- Phillip Wood <phillip.wood@talktalk.net>
- Date
- Oct 31, 2018, 10:15 UTC
- Message-ID
- <20181031101556.27169-1-phillip.wood@talktalk.net>
- In-Reply-To
- <20180912101029.28052-1-phillip.wood@talktalk.net>
From: Phillip Wood <phillip.wood@dunelm.org.uk>
Sorry for the confusion with v3, here are the updated patches.
Thanks to Junio for the feedback on v2. I've updated patch 4 based on those comments, the rest are unchanged.
v1 cover letter:
This is a follow up to pw/rebase-i-author-script-fix, it reduces code duplication and improves rebase's parsing of the author script. After this I'll do another series to share the code to write the author script.
Phillip Wood (5): am: don't die in read_author_script() am: improve author-script error reporting am: rename read_author_script() add read_author_script() to libgit sequencer: use read_author_script()
builtin/am.c | 60 ++-------------- sequencer.c | 192 ++++++++++++++++++++++++++++++++------------------- sequencer.h | 3 + 3 files changed, 128 insertions(+), 127 deletions(-)
-- 2.19.1