[PATCH 0/3] am/rebase: share read_author_script()
- From
- Phillip Wood <phillip.wood@talktalk.net>
- Date
- Sep 12, 2018, 10:10 UTC
- Message-ID
- <20180912101029.28052-1-phillip.wood@talktalk.net>
From: Phillip Wood <phillip.wood@dunelm.org.uk>
This is a follow up to pw/rebase-i-author-script-fix, it reduces code duplication and improves rebase's parsing of the author script. After this I'll do another series to share the code to write the author script.
Phillip Wood (3): am: rename read_author_script() add read_author_script() to libgit sequencer: use read_author_script()
builtin/am.c | 61 ++------------------ sequencer.c | 160 ++++++++++++++++++++++++++++----------------------- sequencer.h | 3 + 3 files changed, 96 insertions(+), 128 deletions(-)
-- 2.18.0