[PATCH v2 00/12] get_short_oid UI improvements
- From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
- Date
- May 1, 2018, 12:06 UTC
- Message-ID
- <20180501120651.15886-1-avarab@gmail.com>
- In-Reply-To
- <20180430220734.30133-1-avarab@gmail.com>
A v2 addressing feedback so far. Comments inline per-patch.
Ævar Arnfjörð Bjarmason (12): sha1-name.c: remove stray newline sha1-array.h: align function arguments
No changes.
git-p4: change "commitish" typo to "committish"
New, I fixed my own "commitish" elsewhere, fixing it here in this unrelated area while I'm at it.
cache.h: add comment explaining the order in object_type
New: Derrick Stolee pointed out why the object type enum used later is ordered that way, explain that with a comment.
sha1-name.c: move around the collect_ambiguous() function
Trivial grammar correction in commit message:
- collect_ambiguous() function is now, which would result in a
+ collect_ambiguous() function is now. Without this we'd then have aget_short_oid: sort ambiguous objects by type, then SHA-1
* Grammar fixes in commit message * Add docs to api-oid-array.txt documenting the new oid_array_for_each() * Document in the commit message why we sort twice * Note inline in sha1-array.c why oid_array_for_each() doesn't sort with a pointer to the API docs. * Add test to assert that we sort objects in the order we expect, and that they're hash sorted within the object types.
get_short_oid: learn to disambiguate by ^{tag}
get_short_oid: learn to disambiguate by ^{blob}No changes.
get_short_oid / peel_onion: ^{tree} should be tree, not treeishs/mean/be/ in subject line (to avoid wrapping in E-Mail).
get_short_oid / peel_onion: ^{commit} should be commit, not committishRewrite commit message, now assumes less context from the rest of the series & is easier to read stand-alone.
config doc: document core.disambiguate
Change commitish to committish, and note the `$sha1:` peel syntax.
get_short_oid: document & warn if we ignore the type selector
New: Explain why we ignore e.g. $sha1^{blob} if there's no blobs with
the $sha1 prefix.Documentation/config.txt | 17 +++++ Documentation/technical/api-oid-array.txt | 17 +++-- cache.h | 13 +++- git-p4.py | 6 +- sha1-array.c | 17 +++++ sha1-array.h | 7 +- sha1-name.c | 80 +++++++++++++++++++---- t/t1512-rev-parse-disambiguation.sh | 58 +++++++++++++--- 8 files changed, 182 insertions(+), 33 deletions(-)
-- 2.17.0.290.gded63e768a