Re: [PATCH v2] diff: add --compact-summary option to complement --stat
- From
Jeff King <peff@peff.net>
- Date
- Jan 18, 2018, 22:48 UTC
- Message-ID
- <20180118224814.GA8473@sigill.intra.peff.net>
- In-Reply-To
- <20180118100546.32251-1-pclouds@gmail.com>
On Thu, Jan 18, 2018 at 05:05:46PM +0700, Nguyễn Thái Ngọc Duy wrote:
Show 9 quoted lines
> This is partly inspired by gerrit web interface which shows diffstat > like this, e.g. with commit 0433d533f1 (notice the "A" column on the > third line): > > Documentation/merge-config.txt | 4 + > builtin/merge.c | 2 + > A t/t5573-pull-verify-signatures.sh | 81 ++++++++++++++++++ > t/t7612-merge-verify-signatures.sh | 45 ++++++++++ > 4 files changed, 132 insertions(+)
I like the general concept. Perusing "git log" output, though, it felt like the summary column was very close to the filenames. What do you think of putting it after the "|", where it is only close to a number?
Something like the patch below (on top of yours, but it probably needs tweaked further for graph_width), which gives:
t/t5573-pull-verify-signatures.sh | A+x 78 ++++++++++++++++++++++++++++
(I know this is a bikeshed, so I'm perfectly willing to take "yuck, I don't like that as well" as a response).
> The new option --compact-summary implements this with a tweak to support > mode change, which is shown in --summary too.
One thing I noticed is that --compact-summary by itself does nothing. Should it imply --stat?
-Peff