git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 7/7] config: flip return value of store_write_*()

From
Jonathan Nieder <jrnieder@gmail.com>
Date
Sep 13, 2017, 21:25 UTC
Message-ID
<20170913212528.GO27425@aiede.mtv.corp.google.com>
In-Reply-To
<20170913171756.v7vzu3a77g2khq7x@sigill.intra.peff.net>
Hi,
Jeff King wrote:
Show 14 quoted lines
> The store_write_section() and store_write_pairs() functions
> are basically high-level wrappers around write(). But their
> return values are flipped from our usual convention, using
> "1" for success and "0" for failure.
>
> Let's flip them to follow the usual write() conventions and
> update all callers. As these are local to config.c, it's
> unlikely that we'd have new callers in any topics in flight
> (which would be silently broken by our change). But just to
> be on the safe side, let's rename them to just
> write_section() and write_pairs().  That also accentuates
> their relationship with write().
>
> Signed-off-by: Jeff King <peff@peff.net>

The caller only cares if it succeeded, right? Could this return the customary 0 vs -1 instead of the number of bytes written?

That would look like the following (as a patch to squash in):
With or without that tweak,
Reviewed-by: Jonathan Nieder <jrnieder@gmail.com>
diff --git i/config.c w/config.c
index 272a32aac0..8f92d452bf 100644
--- i/config.c
+++ w/config.c
@@ -2297,11 +2297,10 @@ static int write_error(const char *filename)
 	return 4;
 }
 
-static ssize_t write_section(int fd, const char *key)
+static int write_section(int fd, const char *key)
 {
 	const char *dot;
-	int i;
-	ssize_t ret;
+	int i, ret;
 	struct strbuf sb = STRBUF_INIT;
 
 	dot = memchr(key, '.', store.baselen);
@@ -2317,16 +2316,15 @@ static ssize_t write_section(int fd, const char *key)
 		strbuf_addf(&sb, "[%.*s]\n", store.baselen, key);
 	}
 
-	ret = write_in_full(fd, sb.buf, sb.len);
+	ret = write_in_full(fd, sb.buf, sb.len) < 0 ? -1 : 0;
 	strbuf_release(&sb);
 
 	return ret;
 }
 
-static ssize_t write_pair(int fd, const char *key, const char *value)
+static int write_pair(int fd, const char *key, const char *value)
 {
-	int i;
-	ssize_t ret;
+	int i, ret;
 	int length = strlen(key + store.baselen + 1);
 	const char *quote = "";
 	struct strbuf sb = STRBUF_INIT;
@@ -2366,7 +2364,7 @@ static ssize_t write_pair(int fd, const char *key, const char *value)
 		}
 	strbuf_addf(&sb, "%s\n", quote);
 
-	ret = write_in_full(fd, sb.buf, sb.len);
+	ret = write_in_full(fd, sb.buf, sb.len) < 0 ? -1 : 0;
 	strbuf_release(&sb);
 
 	return ret;
@@ -2499,8 +2497,7 @@ int git_config_set_multivar_in_file_gently(const char *config_filename,
 		}
 
 		store.key = (char *)key;
-		if (write_section(fd, key) < 0 ||
-		    write_pair(fd, key, value) < 0)
+		if (write_section(fd, key) || write_pair(fd, key, value))
 			goto write_err_out;
 	} else {
 		struct stat st;
@@ -2623,10 +2620,10 @@ int git_config_set_multivar_in_file_gently(const char *config_filename,
 		/* write the pair (value == NULL means unset) */
 		if (value != NULL) {
 			if (store.state == START) {
-				if (write_section(fd, key) < 0)
+				if (write_section(fd, key))
 					goto write_err_out;
 			}
-			if (write_pair(fd, key, value) < 0)
+			if (write_pair(fd, key, value))
 				goto write_err_out;
 		}
 
@@ -2820,7 +2817,7 @@ int git_config_rename_section_in_file(const char *config_filename,
 					continue;
 				}
 				store.baselen = strlen(new_name);
-				if (write_section(out_fd, new_name) < 0) {
+				if (write_section(out_fd, new_name)) {
 					ret = write_error(get_lock_file_path(lock));
 					goto out;
 				}
Previous: Jeff KingNext: Jeff King
Message 43 of 46 in “Bug: git branch --unset-upstream command can nuke config when disk is full.”
  1. demerphqSep 13, 2017
  2. Jeff KingSep 13, 2017
  3. demerphqSep 13, 2017
  4. Jeff KingSep 13, 2017
  5. demerphqSep 13, 2017
  6. Jeff KingSep 13, 2017
  7. demerphqSep 13, 2017
  8. Jeff KingSep 13, 2017
  9. demerphqSep 13, 2017
  10. 0/7 config.c may fail to notice some write() failuresJeff King, Sep 13, 2017
  11. 1/7 config: avoid "write_in_full(fd, buf, len) < len" patternJeff King, Sep 13, 2017
  12. Jonathan NiederSep 13, 2017
  13. Jeff KingSep 13, 2017
  14. Jonathan NiederSep 13, 2017
  15. Jeff KingSep 13, 2017
  16. config: avoid "write_in_full(fd, buf, len) < len" patternJeff King, Sep 13, 2017
  17. Jonathan NiederSep 13, 2017
  18. Jeff KingSep 13, 2017
  19. Jonathan NiederSep 13, 2017
  20. Jonathan NiederSep 13, 2017
  21. Ramsay JonesSep 13, 2017
  22. Ramsay JonesSep 13, 2017
  23. Jeff KingSep 15, 2017
  24. Ramsay JonesSep 15, 2017
  25. Junio C HamanoSep 13, 2017
  26. 2/7 get-tar-commit-id: check write_in_full() return against 0Jeff King, Sep 13, 2017
  27. Jonathan NiederSep 13, 2017
  28. Jeff KingSep 13, 2017
  29. Jeff KingSep 13, 2017
  30. Jonathan NiederSep 13, 2017
  31. Jeff KingSep 15, 2017
  32. 3/7 avoid "write_in_full(fd, buf, len) != len" patternJeff King, Sep 13, 2017
  33. Jonathan NiederSep 13, 2017
  34. Jeff KingSep 15, 2017
  35. 4/7 convert less-trivial versions of "write_in_full() != len"Jeff King, Sep 13, 2017
  36. Jonathan NiederSep 13, 2017
  37. 5/7 pkt-line: check write_in_full() errors against "< 0"Jeff King, Sep 13, 2017
  38. Jonathan NiederSep 13, 2017
  39. 6/7 notes-merge: use ssize_t for write_in_full() return valueJeff King, Sep 13, 2017
  40. Jonathan NiederSep 13, 2017
  41. Jeff KingSep 15, 2017
  42. 7/7 config: flip return value of store_write_*()Jeff King, Sep 13, 2017
  43. Jonathan NiederSep 13, 2017
  44. Jeff KingSep 15, 2017
  45. 8/7 read_pack_header: handle signed/unsigned comparison in read resultJeff King, Sep 13, 2017
  46. Jonathan NiederSep 13, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.