Re: [PATCH 0/5] make interpret-trailers useful for parsing
- From
Jeff King <peff@peff.net>
- Date
- Aug 10, 2017, 18:03 UTC
- Message-ID
- <20170810180326.4kkmawywvdbuzwnp@sigill.intra.peff.net>
- In-Reply-To
- <20170810080246.njjd5zkphytzmlda@sigill.intra.peff.net>
On Thu, Aug 10, 2017 at 04:02:46AM -0400, Jeff King wrote:
Show 15 quoted lines
> On Wed, Aug 09, 2017 at 08:21:47AM -0400, Jeff King wrote: > > > This series teaches interpret-trailers to parse and output just the > > trailers. So now you can do: > > > > $ git log --format=%B -1 8d44797cc91231cd44955279040dc4a1ee0a797f | > > git interpret-trailers --parse > > Signed-off-by: Hartmut Henkel <henkel@vh-s.de> > > Helped-by: Stefan Beller <sbeller@google.com> > > Signed-off-by: Ralf Thielow <ralf.thielow@gmail.com> > > Acked-by: Matthias Rüster <matthias.ruester@gmail.com> > > And here's a v2 that addresses all of the comments except one: Stefan > suggested that --only-existing wasn't a great name. I agree, but I like > everything else less.
Here's a v3 that takes care of that (renaming it to --only-input).
It's otherwise the same as v2, but since the name-change ripples through the remaining patches, I wanted to get v3 in front of people sooner rather than later.
[1/5]: trailer: put process_trailers() options into a struct [2/5]: interpret-trailers: add an option to show only the trailers [3/5]: interpret-trailers: add an option to show only existing trailers [4/5]: interpret-trailers: add an option to normalize output [5/5]: interpret-trailers: add --parse convenience option
Documentation/git-interpret-trailers.txt | 34 +++++++++++--- builtin/interpret-trailers.c | 34 +++++++++++--- t/t7513-interpret-trailers.sh | 76 ++++++++++++++++++++++++++++++++ trailer.c | 68 ++++++++++++++++++++++------ trailer.h | 13 +++++- 5 files changed, 196 insertions(+), 29 deletions(-)