Re: [PATCH v16 0/7] config commit verbose
- From
SZEDER Gábor <szeder@ira.uka.de>
- Date
- May 6, 2016, 14:20 UTC
- Message-ID
- <20160506162058.Horde.toAFyoD2uVNcv2x2Ssx_9zt@webmail.informatik.kit.edu>
- In-Reply-To
- <CAPig+cQO3W4WthHstrVFWziU2RAuNyEzeQwBEyDXG8dghRjECQ@mail.gmail.com>
Quoting Eric Sunshine <sunshine@sunshineco.com>:
Show 21 quoted lines
> On Thu, May 5, 2016 at 3:21 PM, Junio C Hamano <gitster@pobox.com> wrote: >> Pranit Bauva <pranit.bauva@gmail.com> writes: >>> This series of patches add a configuration variable for verbose in >>> git-commit. >>> >>> Changes wrt v15: >>> * Remove the previous patch 7/7 and split the tests. Include one in >>> initial patch 6/7. The other one is introduced in a separate commit >>> after 4/7. >>> * Include tests in patch 3/6 for --no-quiet without -q, multiple verbose, >>> --no-verbose with -v as suggested by Eric Sunshine >> >> Thanks for a pleasant read. Modulo minor readability nits I sent >> separately on 7/7, this looked good. > > Agreed, this version was a more pleasant and coherent read than > previous ones. > > Considering that this series is already at v16 and the 7/7 review > comments were very minor, I'd be fine seeing this series land as-is, > rather than expecting v17.
v16, wow, I totally lost track of this series, sorry.
And I hate to bring this up this late again... at v16 of a now 7 patch series, when all this started out like two months ago as a GSoC mini project... But I do it anyway. Oh well.
A while ago in a related thread Peff remarked about 'git commit's '--quiet' and '--verbose' options:
I think that is a UX mistake, and we would not do
it that way if designing from scratch. But we're stuck with it for
historical reasons (I'd probably name "--verbose" as "--show-diff" or
something if writing it today).http://thread.gmane.org/gmane.comp.version-control.git/289027/focus=289069
Then I replied:
However, that doesn't mean that we have to spread this badly chosen
name from options to config variables, does it? I think that if we
are going to define a new config variable today, then it should be
named properly, and it's better not to call it 'commit.verbose', but
'commit.showDiff' or something.http://thread.gmane.org/gmane.comp.version-control.git/289027/focus=289303
Any thoughts on this? Before a poorly named config variable enters to the codebase and we'll have to maintain it "forever"...