Re: [PATCH v2 3/6] t6300: introduce test_date() helper
On Tue, Sep 01, 2015 at 10:55:41PM +0100, John Keeping wrote:
> I considered moving the test_expect_success into the helper, like with
> test_atom earlier in the file, but it doesn't make the code much more
> concise and we still need either to setup the output outside the test
> case or to escape SQ inside SQ.
Moving it inside also makes it harder to test_expect_failure. :)
Show 5 quoted lines
> test_expect_success 'Check unformatted date fields output' '
> - (git for-each-ref --shell --format="%(refname) %(committerdate) %(authordate)" refs/heads &&
> - git for-each-ref --shell --format="%(refname) %(taggerdate)" refs/tags) >actual &&
> - test_cmp expected actual
> + test_date "" "Mon Jul 3 17:18:43 2006 +0200" "Mon Jul 3 17:18:44 2006 +0200" "Mon Jul 3 17:18:45 2006 +0200"
I notice we end up with rather long lines for some of these. Would:
test_date "" <<-\EOF
Mon Jul 3 17:18:43 2006 +0200
Mon Jul 3 17:18:44 2006 +0200
Mon Jul 3 17:18:45 2006 +0200
EOF
be more readable?
-Peff