Re: [PATCH 1/2] refs.c: make ref_transaction_create a wrapper for ref_transaction_update
- From
Jeff King <peff@peff.net>
- Date
- Nov 20, 2014, 16:00 UTC
- Message-ID
- <20141120160000.GA31738@peff.net>
- In-Reply-To
- <1416433224-29763-2-git-send-email-sbeller@google.com>
On Wed, Nov 19, 2014 at 01:40:23PM -0800, Stefan Beller wrote:
Show 16 quoted lines
> {
> - struct ref_update *update;
> -
> - assert(err);
> -
> - if (transaction->state != REF_TRANSACTION_OPEN)
> - die("BUG: create called for transaction that is not open");
> -
> - if (!new_sha1 || is_null_sha1(new_sha1))
> - die("BUG: create ref with null new_sha1");
> -
> - if (check_refname_format(refname, REFNAME_ALLOW_ONELEVEL)) {
> - strbuf_addf(err, "refusing to create ref with bad name %s",
> - refname);
> - return -1;
> - }You claimed in the cover letter that only BUG messages were changed. But I think this third one is a real user-visible message.
That being said, I think the sum total of the change to the message is s/create/update/, and it's probably fine.
-Peff