git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 2/2] Rename suffixcmp() to ends_with() and invert its result

From
Jonathan Nieder <jrnieder@gmail.com>
Date
Nov 19, 2013, 19:13 UTC
Message-ID
<20131119191322.GA4212@google.com>
In-Reply-To
<20131117083930.4177.79411.chriscool@tuxfamily.org>
Christian Couder wrote:
> Now ends_with() returns 1 when the suffix is present and 0 otherwise.
Sounds good.
[...]
> And in vcs-svn/fast_export.c there was already an ends_with()
> function that did the same thing. Let's used the renamed one
> while at it.

Yes, despite the change in signature this shouldn't slow anything down. Thanks.

For what it's worth,
Reviewed-by: Jonathan Nieder <jrnieder@gmail.com>
Previous: Christian CouderNext: Christian Couder
Message 2 of 6 in “Rename suffixcmp() to ends_with() and invert its result”
  1. 2/2 Rename suffixcmp() to ends_with() and invert its resultChristian Couder, Nov 17, 2013
  2. Jonathan NiederNov 19, 2013
  3. Christian CouderNov 19, 2013
  4. Antoine PelisseNov 19, 2013
  5. Junio C HamanoNov 19, 2013
  6. Christian CouderNov 21, 2013

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.