git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 2/2] Rename suffixcmp() to ends_with() and invert its result

From
Junio C Hamano <gitster@pobox.com>
Date
Nov 19, 2013, 22:28 UTC
Message-ID
<xmqq4n7881s7.fsf@gitster.dls.corp.google.com>
In-Reply-To
<CALWbr2yG7XOhuZa9bf6sXRV=m49dTPNyPZ9JUU2-_2G8ZJsCTg@mail.gmail.com>
Antoine Pelisse <apelisse@gmail.com> writes:
Show 24 quoted lines
> On Tue, Nov 19, 2013 at 10:04 PM, Christian Couder
> <chriscool@tuxfamily.org> wrote:
>> To avoid spamming the list again, I am going to send the following
>> patches from the 86 patch long series to replace prefixcmp() with
>> starts_with():
>>
>> [PATCH v2 00/86] replace prefixcmp() with starts_with()
>> [PATCH v2 01/86] strbuf: add starts_with() to be used instead of prefixcmp()
>> [PATCH v2 02/86] diff: replace prefixcmp() with starts_with()
>> [PATCH v2 08/86] transport*: replace prefixcmp() with starts_with()
>> [PATCH v2 40/86] environment: replace prefixcmp() with starts_with()
>> [PATCH v2 86/86] strbuf: remove prefixcmp() as it has been replaced with starts_with()
>>
>> If there are no problems with them, then I will suppose that most of
>> the patches are ok and probably send them all unless I am asked not
>> to.
>
> I'm not exactly sure I understand the point of not squashing all those
> patches together ?
> It's not like one is going without the others, or that the commit
> message provides some new information (except for the name of the
> file, but that is not very relevant either). The downside is that it's
> _many_ messages to bypass when reading mails from small-screen devices
> :-)

The only plausible reason I could think of is to avoid clashing with topics in-flight, but then the approach to produce per-file patch is not perfect for that purpose, either, when more than one topic in flight touch the same file at different places.

I'd say probably the best organization would be something like:
 * A set of clean-up patches to normalize oddball usages of existing
   functions (e.g. normalize 'prefixcmp(a,b) != 0' in some file(s)
   to 'prefixcmp(a,b)');
 * A single patch to introduce the new function(s), to be applied on
   top of 1.8.5;
 * A large patch to convert all uses of prefixcmp to starts_with and
   suffixcmp to ends_with in the 1.8.5 codebase;
 * A patch for each topic in flight to convert newly introduced
   prefixcmp/suffixcmp to starts_with/ends_with, to be applied after
   the topic graduates to 'master' after 1.8.5; and then finally
 * A separate patch to remove prefixcmp and suffixcmp, to be applied
   after _all_ in-flight topic has graduated to 'master'.
Previous: Antoine PelisseNext: Christian Couder
Message 5 of 6 in “Rename suffixcmp() to ends_with() and invert its result”
  1. 2/2 Rename suffixcmp() to ends_with() and invert its resultChristian Couder, Nov 17, 2013
  2. Jonathan NiederNov 19, 2013
  3. Christian CouderNov 19, 2013
  4. Antoine PelisseNov 19, 2013
  5. Junio C HamanoNov 19, 2013
  6. Christian CouderNov 21, 2013

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.