git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 00/18] Extending the shelf-life of "git describe" output

From
Jeff King <peff@peff.net>
Date
Jul 3, 2012, 20:24 UTC
Message-ID
<20120703202452.GA24984@sigill.intra.peff.net>
In-Reply-To
<7vtxxotx2n.fsf@alter.siamese.dyndns.org>
On Tue, Jul 03, 2012 at 01:21:36PM -0700, Junio C Hamano wrote:
Show 11 quoted lines
> Jeff King <peff@peff.net> writes:
> 
> > What happens if I set multiple flags? One or more of them will be
> > ignored (you _could_ try to establish a hierarchy, for example that
> > TREEISH is a superset of COMMITISH, but that could not handle the *_only
> > cases, which really are mutually exclusive). IOW, I think these are not
> > really flags but rather enum elements.
> 
> Yes, I was aware of that.  I counted five useful ones (see the new
> ones near the tip of 'pu') but there may be others, so you cannot
> fit in 2 bits and would need 3 bits.

I am not worried about the bits, only that adding a new 'enum disambiguation_type' parameter would be a pain, as most places would just be passing 0. But it would enforce the mutual exclusion at compile time.

> I actually am thinking to move these bit assignments backto
> sha1_name.c and make them private, as get_sha1_tree() and friends
> are easier to understand public interface functions than
> get_sha1_typish(... I_WANT_COMMIT|I_WANT_COMMITTISH|...).

Yeah, I think that might be sane. If you really wanted to be flexible anyway, you would let the caller pass a custom disambiguation function (which I suspect describe would want for handling the "must come at this point in the history" rule).

-Peff
Previous: Junio C Hamano
Message 31 of 31 in “Extending the shelf-life of "git describe" output”
  1. 00/18 Extending the shelf-life of "git describe" outputJunio C Hamano, Jul 2, 2012
  2. 01/18 sha1_name.c: indentation fixJunio C Hamano, Jul 2, 2012
  3. 02/18 sha1_name.c: hide get_sha1_with_context_1() uglinessJunio C Hamano, Jul 2, 2012
  4. 03/18 sha1_name.c: get rid of ugly get_sha1_with_mode_1()Junio C Hamano, Jul 2, 2012
  5. Matthieu MoyJul 3, 2012
  6. Junio C HamanoJul 3, 2012
  7. Matthieu MoyJul 4, 2012
  8. 04/18 sha1_name.c: get rid of get_sha1_with_mode()Junio C Hamano, Jul 2, 2012
  9. 05/18 sha1_name.c: clarify what "fake" is for in find_short_object_filename()Junio C Hamano, Jul 2, 2012
  10. 06/18 sha1_name.c: rename "now" to "current"Junio C Hamano, Jul 2, 2012
  11. 07/18 sha1_name.c: refactor find_short_packed_object()Junio C Hamano, Jul 2, 2012
  12. 08/18 sha1_name.c: correct misnamed "canonical" and "res"Junio C Hamano, Jul 2, 2012
  13. 09/18 sha1_name.c: restructure disambiguation of short namesJunio C Hamano, Jul 2, 2012
  14. 10/18 sha1_name.c: allow get_short_sha1() to take other flagsJunio C Hamano, Jul 2, 2012
  15. 11/18 sha1_name.c: teach get_short_sha1() a commit-only optionJunio C Hamano, Jul 2, 2012
  16. 12/18 sha1_name.c: get_describe_name() by definition groks only commitsJunio C Hamano, Jul 2, 2012
  17. 13/18 sha1_name.c: get_sha1_1() takes lookup flagsJunio C Hamano, Jul 2, 2012
  18. 14/18 sha1_name.c: many short names can only be committishJunio C Hamano, Jul 2, 2012
  19. Junio C HamanoJul 2, 2012
  20. 15/18 sha1_name.c: teach lookup context to get_sha1_with_context()Junio C Hamano, Jul 2, 2012
  21. 16/18 sha1_name.c: introduce get_sha1_committish()Junio C Hamano, Jul 2, 2012
  22. 17/18 revision.c: allow handle_revision_arg() to take other flagsJunio C Hamano, Jul 2, 2012
  23. 18/18 revision.c: the "log" family, except for "show", takes committishJunio C Hamano, Jul 2, 2012
  24. Jeff KingJul 3, 2012
  25. Junio C HamanoJul 3, 2012
  26. Junio C HamanoJul 3, 2012
  27. Jeff KingJul 3, 2012
  28. Junio C HamanoJul 3, 2012
  29. Jeff KingJul 3, 2012
  30. Junio C HamanoJul 3, 2012
  31. Jeff KingJul 3, 2012

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.