git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 00/18] Extending the shelf-life of "git describe" output

From
Jeff King <peff@peff.net>
Date
Jul 3, 2012, 19:34 UTC
Message-ID
<20120703193410.GA20503@sigill.intra.peff.net>
In-Reply-To
<7vy5n0vg9l.fsf@alter.siamese.dyndns.org>
On Tue, Jul 03, 2012 at 11:41:42AM -0700, Junio C Hamano wrote:
Show 5 quoted lines
> Jeff King <peff@peff.net> writes:
> 
> > It looks right to me (and certainly fixes the behavior I mentioned).
> 
> OK, I have further updates on the topic; pushed out to 'pu'.
Looks reasonable to me. One thing I wondered about is in:
Show 15 quoted lines
> static int get_short_sha1(const char *name, int len, unsigned char *sha1,
>			  unsigned flags)
> {
> [...]
>	memset(&ds, 0, sizeof(ds));
>	if (flags & GET_SHA1_COMMIT)
>		ds.fn = disambiguate_commit_only;
>	else if (flags & GET_SHA1_COMMITTISH)
>		ds.fn = disambiguate_committish_only;
>	else if (flags & GET_SHA1_TREE)
>		ds.fn = disambiguate_tree_only;
>	else if (flags & GET_SHA1_TREEISH)
>		ds.fn = disambiguate_treeish_only;
>	else if (flags & GET_SHA1_BLOB)
>		ds.fn = disambiguate_blob_only;

What happens if I set multiple flags? One or more of them will be ignored (you _could_ try to establish a hierarchy, for example that TREEISH is a superset of COMMITISH, but that could not handle the *_only cases, which really are mutually exclusive). IOW, I think these are not really flags but rather enum elements.

It is probably an OK trade-off since we are also stuffing true flags like GET_SHA1_QUIETLY in the same field, and we don't want to make the parameter list too unwieldy by splitting out the enum. But it might be worth throwing a comment into cache.h that a certain set of the flags are mutually exclusive. Or I guess you could mask off that part and make sure only one bit was set, which would catch the error at run-time. But I think a comment is probably sufficient.

-Peff
Previous: Junio C HamanoNext: Junio C Hamano
Message 29 of 31 in “Extending the shelf-life of "git describe" output”
  1. 00/18 Extending the shelf-life of "git describe" outputJunio C Hamano, Jul 2, 2012
  2. 01/18 sha1_name.c: indentation fixJunio C Hamano, Jul 2, 2012
  3. 02/18 sha1_name.c: hide get_sha1_with_context_1() uglinessJunio C Hamano, Jul 2, 2012
  4. 03/18 sha1_name.c: get rid of ugly get_sha1_with_mode_1()Junio C Hamano, Jul 2, 2012
  5. Matthieu MoyJul 3, 2012
  6. Junio C HamanoJul 3, 2012
  7. Matthieu MoyJul 4, 2012
  8. 04/18 sha1_name.c: get rid of get_sha1_with_mode()Junio C Hamano, Jul 2, 2012
  9. 05/18 sha1_name.c: clarify what "fake" is for in find_short_object_filename()Junio C Hamano, Jul 2, 2012
  10. 06/18 sha1_name.c: rename "now" to "current"Junio C Hamano, Jul 2, 2012
  11. 07/18 sha1_name.c: refactor find_short_packed_object()Junio C Hamano, Jul 2, 2012
  12. 08/18 sha1_name.c: correct misnamed "canonical" and "res"Junio C Hamano, Jul 2, 2012
  13. 09/18 sha1_name.c: restructure disambiguation of short namesJunio C Hamano, Jul 2, 2012
  14. 10/18 sha1_name.c: allow get_short_sha1() to take other flagsJunio C Hamano, Jul 2, 2012
  15. 11/18 sha1_name.c: teach get_short_sha1() a commit-only optionJunio C Hamano, Jul 2, 2012
  16. 12/18 sha1_name.c: get_describe_name() by definition groks only commitsJunio C Hamano, Jul 2, 2012
  17. 13/18 sha1_name.c: get_sha1_1() takes lookup flagsJunio C Hamano, Jul 2, 2012
  18. 14/18 sha1_name.c: many short names can only be committishJunio C Hamano, Jul 2, 2012
  19. Junio C HamanoJul 2, 2012
  20. 15/18 sha1_name.c: teach lookup context to get_sha1_with_context()Junio C Hamano, Jul 2, 2012
  21. 16/18 sha1_name.c: introduce get_sha1_committish()Junio C Hamano, Jul 2, 2012
  22. 17/18 revision.c: allow handle_revision_arg() to take other flagsJunio C Hamano, Jul 2, 2012
  23. 18/18 revision.c: the "log" family, except for "show", takes committishJunio C Hamano, Jul 2, 2012
  24. Jeff KingJul 3, 2012
  25. Junio C HamanoJul 3, 2012
  26. Junio C HamanoJul 3, 2012
  27. Jeff KingJul 3, 2012
  28. Junio C HamanoJul 3, 2012
  29. Jeff KingJul 3, 2012
  30. Junio C HamanoJul 3, 2012
  31. Jeff KingJul 3, 2012

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.