git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v4 01/18] sha1_name.c: indentation fix

From
Junio C Hamano <gitster@pobox.com>
Date
Jul 2, 2012, 22:33 UTC
Message-ID
<1341268449-27801-2-git-send-email-gitster@pobox.com>
In-Reply-To
<1341268449-27801-1-git-send-email-gitster@pobox.com>
Signed-off-by: Junio C Hamano <gitster@pobox.com>
---
 sha1_name.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/sha1_name.c b/sha1_name.c
index 03ffc2c..5b0c845 100644
--- a/sha1_name.c
+++ b/sha1_name.c
@@ -103,10 +103,10 @@ static int find_short_packed_object(int len, const unsigned char *match, unsigne
 		}
 		if (first < num) {
 			const unsigned char *now, *next;
-		       now = nth_packed_object_sha1(p, first);
+			now = nth_packed_object_sha1(p, first);
 			if (match_sha(len, match, now)) {
 				next = nth_packed_object_sha1(p, first+1);
-			       if (!next|| !match_sha(len, match, next)) {
+				if (!next|| !match_sha(len, match, next)) {
 					/* unique within this pack */
 					if (!found) {
 						found_sha1 = now;
-- 
1.7.11.1.212.g52fe12e
Previous: Junio C HamanoNext: Junio C Hamano
Message 2 of 31 in “Extending the shelf-life of "git describe" output”
  1. 00/18 Extending the shelf-life of "git describe" outputJunio C Hamano, Jul 2, 2012
  2. 01/18 sha1_name.c: indentation fixJunio C Hamano, Jul 2, 2012
  3. 02/18 sha1_name.c: hide get_sha1_with_context_1() uglinessJunio C Hamano, Jul 2, 2012
  4. 03/18 sha1_name.c: get rid of ugly get_sha1_with_mode_1()Junio C Hamano, Jul 2, 2012
  5. Matthieu MoyJul 3, 2012
  6. Junio C HamanoJul 3, 2012
  7. Matthieu MoyJul 4, 2012
  8. 04/18 sha1_name.c: get rid of get_sha1_with_mode()Junio C Hamano, Jul 2, 2012
  9. 05/18 sha1_name.c: clarify what "fake" is for in find_short_object_filename()Junio C Hamano, Jul 2, 2012
  10. 06/18 sha1_name.c: rename "now" to "current"Junio C Hamano, Jul 2, 2012
  11. 07/18 sha1_name.c: refactor find_short_packed_object()Junio C Hamano, Jul 2, 2012
  12. 08/18 sha1_name.c: correct misnamed "canonical" and "res"Junio C Hamano, Jul 2, 2012
  13. 09/18 sha1_name.c: restructure disambiguation of short namesJunio C Hamano, Jul 2, 2012
  14. 10/18 sha1_name.c: allow get_short_sha1() to take other flagsJunio C Hamano, Jul 2, 2012
  15. 11/18 sha1_name.c: teach get_short_sha1() a commit-only optionJunio C Hamano, Jul 2, 2012
  16. 12/18 sha1_name.c: get_describe_name() by definition groks only commitsJunio C Hamano, Jul 2, 2012
  17. 13/18 sha1_name.c: get_sha1_1() takes lookup flagsJunio C Hamano, Jul 2, 2012
  18. 14/18 sha1_name.c: many short names can only be committishJunio C Hamano, Jul 2, 2012
  19. Junio C HamanoJul 2, 2012
  20. 15/18 sha1_name.c: teach lookup context to get_sha1_with_context()Junio C Hamano, Jul 2, 2012
  21. 16/18 sha1_name.c: introduce get_sha1_committish()Junio C Hamano, Jul 2, 2012
  22. 17/18 revision.c: allow handle_revision_arg() to take other flagsJunio C Hamano, Jul 2, 2012
  23. 18/18 revision.c: the "log" family, except for "show", takes committishJunio C Hamano, Jul 2, 2012
  24. Jeff KingJul 3, 2012
  25. Junio C HamanoJul 3, 2012
  26. Junio C HamanoJul 3, 2012
  27. Jeff KingJul 3, 2012
  28. Junio C HamanoJul 3, 2012
  29. Jeff KingJul 3, 2012
  30. Junio C HamanoJul 3, 2012
  31. Jeff KingJul 3, 2012

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.