git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 08/13] credential: make relevance of http path configurable

From
Jeff King <peff@peff.net>
Date
Nov 24, 2011, 11:03 UTC
Message-ID
<20111124110356.GF8417@sigill.intra.peff.net>
In-Reply-To
<20111124105801.GA6168@sigill.intra.peff.net>

When parsing a URL into a credential struct, we carefully record each part of the URL, including the path on the remote host, and use the result as part of the credential context.

This had two practical implications:
  1. Credential helpers which store a credential for later
     access are likely to use the "path" portion as part of
     the storage key. That means that a request to
       https://example.com/foo.git
     would not use the same credential that was stored in an
     earlier request for:
       https://example.com/bar.git
  2. The prompt shown to the user includes all relevant
     context, including the path.

In most cases, however, users will have a single password per host. The behavior in (1) will be inconvenient, and the prompt in (2) will be overly long.

This patch introduces a config option to toggle the relevance of http paths. When turned on, we use the path as before. When turned off, we drop the path component from the context: helpers don't see it, and it does not appear in the prompt.

This is nothing you couldn't do with a clever credential helper at the start of your stack, like:

  [credential "http://"]
	helper = "f() { grep -v ^path= ; }; f"
	helper = your_real_helper
But doing this:
  [credential]
	useHttpPath = false

is way easier and more readable. Furthermore, since most users will want the "off" behavior, that is the new default. Users who want it "on" can set the variable (either for all credentials, or just for a subset using credential.*.useHttpPath).

Signed-off-by: Jeff King <peff@peff.net>
---
 credential.c           |   14 ++++++++++++++
 credential.h           |    3 ++-
 t/t0300-credentials.sh |   29 +++++++++++++++++++++++++++++
 t/t5550-http-fetch.sh  |    2 +-
 4 files changed, 46 insertions(+), 2 deletions(-)
diff --git a/credential.c b/credential.c
index 06e4e15..36ff0ec 100644
--- a/credential.c
+++ b/credential.c
@@ -69,16 +69,30 @@ static int credential_config_callback(const char *var, const char *value,
 		if (!c->username)
 			c->username = xstrdup(value);
 	}
+	else if (!strcmp(key, "usehttppath"))
+		c->use_http_path = git_config_bool(var, value);
 
 	return 0;
 }
 
+static int proto_is_http(const char *s)
+{
+	if (!s)
+		return 0;
+	return !strcmp(s, "https") || !strcmp(s, "http");
+}
+
 static void credential_apply_config(struct credential *c)
 {
 	if (c->configured)
 		return;
 	git_config(credential_config_callback, c);
 	c->configured = 1;
+
+	if (!c->use_http_path && proto_is_http(c->protocol)) {
+		free(c->path);
+		c->path = NULL;
+	}
 }
 
 static void credential_describe(struct credential *c, struct strbuf *out)
diff --git a/credential.h b/credential.h
index e504272..96ea41b 100644
--- a/credential.h
+++ b/credential.h
@@ -6,7 +6,8 @@
 struct credential {
 	struct string_list helpers;
 	unsigned approved:1,
-		 configured:1;
+		 configured:1,
+		 use_http_path:1;
 
 	char *username;
 	char *password;
diff --git a/t/t0300-credentials.sh b/t/t0300-credentials.sh
index 57751a1..89a8531 100755
--- a/t/t0300-credentials.sh
+++ b/t/t0300-credentials.sh
@@ -247,4 +247,33 @@ test_expect_success 'pull username from config' '
 	EOF
 '
 
+test_expect_success 'http paths can be part of context' '
+	check fill "verbatim foo bar" <<-\EOF &&
+	protocol=https
+	host=example.com
+	path=foo.git
+	--
+	username=foo
+	password=bar
+	--
+	verbatim: get
+	verbatim: protocol=https
+	verbatim: host=example.com
+	EOF
+	test_config credential.https://example.com.useHttpPath true &&
+	check fill "verbatim foo bar" <<-\EOF
+	protocol=https
+	host=example.com
+	path=foo.git
+	--
+	username=foo
+	password=bar
+	--
+	verbatim: get
+	verbatim: protocol=https
+	verbatim: host=example.com
+	verbatim: path=foo.git
+	EOF
+'
+
 test_done
diff --git a/t/t5550-http-fetch.sh b/t/t5550-http-fetch.sh
index 18f4d59..dd073d1 100755
--- a/t/t5550-http-fetch.sh
+++ b/t/t5550-http-fetch.sh
@@ -53,7 +53,7 @@ test_expect_success 'setup askpass helpers' '
 '
 
 expect_askpass() {
-	dest=$HTTPD_DEST/auth/repo.git
+	dest=$HTTPD_DEST
 	{
 		case "$1" in
 		none)
-- 
1.7.7.4.5.gb32a5
Previous: Jeff KingNext: Jeff King
Message 13 of 49 in “credential helpers, take two”
  1. 0/13 credential helpers, take twoJeff King, Nov 24, 2011
  2. 01/13 test-lib: add test_config_global variantJeff King, Nov 24, 2011
  3. 02/13 t5550: fix typoJeff King, Nov 24, 2011
  4. 03/13 introduce credentials APIJeff King, Nov 24, 2011
  5. Junio C HamanoNov 28, 2011
  6. Jeff KingNov 29, 2011
  7. Junio C HamanoNov 29, 2011
  8. Jeff KingNov 29, 2011
  9. 04/13 credential: add function for parsing url componentsJeff King, Nov 24, 2011
  10. 05/13 http: use credential API to get passwordsJeff King, Nov 24, 2011
  11. 06/13 credential: apply helper configJeff King, Nov 24, 2011
  12. 07/13 credential: add credential.*.usernameJeff King, Nov 24, 2011
  13. 08/13 credential: make relevance of http path configurableJeff King, Nov 24, 2011
  14. 09/13 docs: end-user documentation for the credential subsystemJeff King, Nov 24, 2011
  15. 10/13 credentials: add "cache" helperJeff King, Nov 24, 2011
  16. Eric SunshineNov 24, 2011
  17. Junio C HamanoNov 29, 2011
  18. Jeff KingNov 29, 2011
  19. 11/13 strbuf: add strbuf_add*_urlencodeJeff King, Nov 24, 2011
  20. Junio C HamanoNov 29, 2011
  21. Jeff KingNov 29, 2011
  22. René ScharfeNov 29, 2011
  23. Jeff KingNov 30, 2011
  24. Junio C HamanoNov 30, 2011
  25. René ScharfeNov 30, 2011
  26. 12/13 credentials: add "store" helperJeff King, Nov 24, 2011
  27. Eric SunshineNov 24, 2011
  28. Jeff KingNov 24, 2011
  29. Junio C HamanoNov 29, 2011
  30. Jeff KingNov 29, 2011
  31. 13/13 t: add test harness for external credential helpersJeff King, Nov 24, 2011
  32. Erik Faye-LundNov 24, 2011
  33. Jeff KingNov 24, 2011
  34. Erik Faye-LundNov 24, 2011
  35. 0/6 echo usernames as they are typedJeff King, Nov 27, 2011
  36. 1/6 move git_getpass to its own source fileJeff King, Nov 27, 2011
  37. 2/6 refactor git_getpass into generic prompt functionJeff King, Nov 27, 2011
  38. 3/6 stub out getpass_echo functionJeff King, Nov 27, 2011
  39. 4/6 prompt: add PROMPT_ECHO flagJeff King, Nov 27, 2011
  40. 5/6 credential: use git_prompt instead of git_getpassJeff King, Nov 27, 2011
  41. 6/6 compat/getpass: add a /dev/tty implementationJeff King, Nov 27, 2011
  42. Junio C HamanoNov 27, 2011
  43. Erik Faye-LundNov 27, 2011
  44. Jeff KingNov 28, 2011
  45. Erik Faye-LundNov 28, 2011
  46. Jeff KingNov 28, 2011
  47. Frans KlaverNov 28, 2011
  48. Erik Faye-LundNov 28, 2011
  49. Jeff KingNov 28, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.