Re: [PATCH 11/14] revert: Introduce a layer of indirection over pick_commits
- From
Jonathan Nieder <jrnieder@gmail.com>
- Date
- Jul 6, 2011, 10:37 UTC
- Message-ID
- <20110706103734.GL15682@elie>
- In-Reply-To
- <1309938868-2028-12-git-send-email-artagnon@gmail.com>
Ramkumar Ramachandra wrote:
> Write a new function called process_continuation to prepare a > todo_list to call pick_commits with; the job of pick_commits is > simplified into performing the tasks listed in todo_list.
Why is it called process_continuation? What is its responsibility? When would I call it?
Show 6 quoted lines
> + /* > + * Decide what to do depending on the arguments; a fresh > + * cherry-pick should be handled differently from an existing > + * one that is being continued > + */ > + res = process_continuation(&opts);
Is this the new sole entry point to the cherry-pick/revert machinery? In that case, I'd be mildly tempted to call it something crazy like start_or_continue_replay(), and even more tempted to split it into separate entry points for new_replay(), continue_replay(), abort_replay(), and remove_replay_state() (but please don't trust me about the names; this is just to get the idea across).