git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [1.8.0] Provide proper remote ref namespaces

From
Johan Herland <johan@herland.net>
Date
Feb 2, 2011, 15:51 UTC
Message-ID
<201102021651.21669.johan@herland.net>
In-Reply-To
<AANLkTimqQtLB--7pwwTALmcchnNCX0nm4Rfx8w1gp74T@mail.gmail.com>
On Wednesday 02 February 2011, Santi Béjar wrote:
Show 56 quoted lines
> On Wednesday 02 February 2011, Johan Herland wrote:
> > Proposal:
> >
> > Currently, git stores remote refs in the local repo by default as
> > follows:
> >
> >  Remote repo    ->   Local repo
> >  ---------------------------------------------------------
> >  HEAD                refs/remotes/$remote/HEAD  (implicit)
> >  refs/heads/*        refs/remotes/$remote/*
> >  refs/tags/*         refs/tags/*         (implicit, autofollow)
> >  refs/replace/*      (TBD) 
> >  refs/notes/*        (TBD)
> >
> > Instead, we should change the default ref mappings into the
> > following:
> >
> >  Remote repo    ->   Local repo
> >  --------------------------------------------------
> >  HEAD                refs/remotes/$remote/HEAD
> >  refs/heads/*        refs/remotes/$remote/heads/*
> >  refs/tags/*         refs/remotes/$remote/tags/*
> >  refs/replace/*      refs/remotes/$remote/replace/*
> >  refs/notes/*        refs/remotes/$remote/notes/*
>
> [...]
>
> > - We might want to generalize the handling of "$remote/$head" into
> > allowing shorthands like "$remote/$tag", "$remote/$replace" and
> > "$remote/$note" as well (provided, of course, that they match
> > unambiguously).
>
> [...]
>
> > [2]: When looking up a shorthand tag name (e.g. v1.7.4): If a local
> > tag (refs/tags/v1.7.4) is found, then we have an unambiguous match.
> > If no local tag is found, we look up the tag name in all configured
> > remotes (using the method described in [1]). If the tag name exists
> > in one or more remotes, and those remotes all agree on its ultimate
> > object name (after applying e.g. ^{commit} or whatever is
> > appropriate in the context of the lookup), then we also have an
> > unambiguous match. However, if the tag name exists in multiple
> > remotes, and they do NOT all agree on its ultimate object name,
> > then the shorthand tag name is ambiguous and the lookup fails. The
> > user can always resolve this ambiguity by creating a local tag
> > (refs/tags/v1.7.4) pointing to the desired object.
>
> And the other way around. What would be the output of "git name-rev"
> , "git describe", "--decorate", and such? $remote/tags/$tag?
> $remote/$tag? $tag?
>
> I would say $remote/$tag for "git name-rev" and "--decorate" but $tag
> for "git describe" as it is usually used to create files, i.e.
> git-1.7.4.261.g705f.tar.gz. And I think many people, me included, do
> not expect to have an / in the "git describe" output, at least in the
> default output (in contrast with the --all flag).
Thanks for raising an important point.

I don't buy the file name creation argument, as 'describe' is used from many different contexts, and file name creation is nowhere documented as one of its primary objectives.

Still, the objective of 'describe' is to create a human-readable string that tries to say something meaningful about a commit in relation to its preceding history, while at the same time uniquely identifying the commit. The "uniquely identifying" part is taken care of by the "-g<SHA1>" part of the output, while the initial "<tagname>-<n>" part makes it human-friendly. Therefore, we only care that the <tagname> is fairly unambiguous in the mind of the reader. From this perspective, which of the alternatives makes more sense? I would disqualify "$remote/$tag" and "$remote/tags/$tag", since the $remote name is repo-specific, and 'describe' output is often passed around between multiple developers/repos. Hence, I think that "$tag" is a good choice for 'describe'. If "$tag" is ambiguous in the current repo, then an "ambiguous tag" tag warning can be printed, but I would still use "$tag".

When it comes to 'name-rev' and '--decorate', those are (AFAICS) much more repo-specific, and seldom passed between users. Also, they don't have the "-g<SHA1>" part from the 'describe' output. Hence, in this case, I consider unique identification (unambiguity) much more important than not displaying $remote names. Therefore, I'd propose using the shortest unambiguous alternative.

Show 8 quoted lines
> Another point to consider is if we want a default remote for tags, a
> config tags.defaultRemote (TBD), defaulting to origin, specifying the
> default remote for tags. There would be a hierarchy: local tags,
> default remote tags, remote tags. With this if one tag is on multiple
> remote the tag from the default remote always wins.
>
> In this way all the tag related input/output would no change much.
> For example all the decoration would be $tag instead of origin/tag.

Agreed, tags.defaultRemote (or tags.preferredRemote if I'm allowed to bikeshed) may be a valuable addition. Another way to achieve this would be to explicitly copy tags from the preferred remote (e.g. origin) directly into refs/tags. I.e. in addition to the (new) default tag refspec

	+refs/tags/*:refs/remotes/origin/tags/*
you could add an _additional_ refspec
	refs/tags/*:refs/tags/*

that would also copy all of origin's tags directly into your local tag namespace.

Thanks for the feedback! :)
...Johan
-- 
Johan Herland, <johan@herland.net>
www.herland.net
Previous: Santi BéjarNext: Santi Béjar
Message 10 of 104 in “[1.8.0] Remote tag namespace”
  1. Nguyen Thai Ngoc DuyFeb 1, 2011
  2. Leo RazoumovFeb 1, 2011
  3. Marc BranchaudFeb 1, 2011
  4. Nguyen Thai Ngoc DuyFeb 1, 2011
  5. Marc BranchaudFeb 2, 2011
  6. Jeff KingFeb 1, 2011
  7. Sverre RabbelierFeb 1, 2011
  8. [1.8.0] Provide proper remote ref namespacesJohan Herland, Feb 2, 2011
  9. Santi BéjarFeb 2, 2011
  10. Johan HerlandFeb 2, 2011
  11. Santi BéjarFeb 2, 2011
  12. Nguyen Thai Ngoc DuyFeb 3, 2011
  13. Johan HerlandFeb 3, 2011
  14. Nguyen Thai Ngoc DuyFeb 3, 2011
  15. Johan HerlandFeb 3, 2011
  16. Santi BéjarFeb 3, 2011
  17. Nguyen Thai Ngoc DuyFeb 3, 2011
  18. Junio C HamanoFeb 4, 2011
  19. Johan HerlandFeb 5, 2011
  20. Kevin P. FlemingFeb 5, 2011
  21. Dmitry PotapovFeb 5, 2011
  22. Johan HerlandFeb 6, 2011
  23. Dmitry PotapovFeb 6, 2011
  24. Nicolas PitreFeb 6, 2011
  25. Dmitry PotapovFeb 6, 2011
  26. Johan HerlandFeb 6, 2011
  27. Dmitry PotapovFeb 6, 2011
  28. Johan HerlandFeb 6, 2011
  29. Dmitry PotapovFeb 7, 2011
  30. Bernhard R. LinkFeb 7, 2011
  31. Dmitry PotapovFeb 8, 2011
  32. Matthieu MoyFeb 6, 2011
  33. Johan HerlandFeb 6, 2011
  34. Matthieu MoyFeb 6, 2011
  35. Johan HerlandFeb 7, 2011
  36. Jeff KingFeb 7, 2011
  37. Johan HerlandFeb 7, 2011
  38. Sverre RabbelierFeb 7, 2011
  39. Johan HerlandFeb 7, 2011
  40. Nguyen Thai Ngoc DuyFeb 7, 2011
  41. Jeff KingFeb 7, 2011
  42. Johan HerlandFeb 8, 2011
  43. Jakub NarebskiFeb 11, 2011
  44. Johan HerlandFeb 13, 2011
  45. Junio C HamanoFeb 14, 2011
  46. Johan HerlandFeb 14, 2011
  47. Jakub NarebskiFeb 14, 2011
  48. Junio C HamanoFeb 14, 2011
  49. Re* [1.8.0] Provide proper remote ref namespacesJunio C Hamano, Feb 14, 2011
  50. Jay SoffianFeb 14, 2011
  51. Sverre RabbelierFeb 14, 2011
  52. Jay SoffianFeb 14, 2011
  53. Jonathan NiederFeb 14, 2011
  54. Jay SoffianFeb 14, 2011
  55. Jonathan NiederFeb 14, 2011
  56. Matthieu MoyFeb 14, 2011
  57. Jeff KingFeb 14, 2011
  58. Sverre RabbelierFeb 14, 2011
  59. Jonathan NiederFeb 14, 2011
  60. Junio C HamanoFeb 14, 2011
  61. Junio C HamanoFeb 14, 2011
  62. Johan HerlandFeb 15, 2011
  63. Junio C HamanoFeb 15, 2011
  64. push.default: Rename 'tracking' to 'upstream'Johan Herland, Feb 16, 2011
  65. Junio C HamanoFeb 16, 2011
  66. Matthieu MoyFeb 16, 2011
  67. Martin von ZweigbergkFeb 16, 2011
  68. Jakub NarebskiFeb 16, 2011
  69. Matthieu MoyFeb 16, 2011
  70. Sverre RabbelierFeb 16, 2011
  71. Junio C HamanoFeb 16, 2011
  72. Sverre RabbelierFeb 16, 2011
  73. Junio C HamanoFeb 16, 2011
  74. Martin von ZweigbergkFeb 18, 2011
  75. Martin von ZweigbergkFeb 18, 2011
  76. Bernhard R. LinkFeb 16, 2011
  77. Jakub NarebskiFeb 14, 2011
  78. Marc BranchaudFeb 14, 2011
  79. Nicolas PitreFeb 14, 2011
  80. Junio C HamanoFeb 14, 2011
  81. Nicolas PitreFeb 14, 2011
  82. Sverre RabbelierFeb 14, 2011
  83. Matthieu MoyFeb 7, 2011
  84. Dmitry PotapovFeb 7, 2011
  85. Nicolas PitreFeb 5, 2011
  86. Jeff KingFeb 5, 2011
  87. Nicolas PitreFeb 5, 2011
  88. Johan HerlandFeb 5, 2011
  89. Junio C HamanoFeb 6, 2011
  90. Marc BranchaudFeb 7, 2011
  91. Junio C HamanoFeb 7, 2011
  92. Nicolas PitreFeb 7, 2011
  93. Jeff KingFeb 7, 2011
  94. Nicolas PitreFeb 7, 2011
  95. Jeff KingFeb 7, 2011
  96. Nicolas PitreFeb 7, 2011
  97. Jeff KingFeb 7, 2011
  98. Johan HerlandFeb 1, 2011
  99. Nicolas PitreFeb 7, 2011
  100. Dmitry PotapovFeb 8, 2011
  101. Johan HerlandFeb 8, 2011
  102. Enrico WeigeltFeb 8, 2011
  103. Junio C HamanoFeb 8, 2011
  104. Johan HerlandFeb 9, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.