Re: [PATCH 2/3] Submodules: Add the new "fetch" config option for fetch and pull
- From
Jonathan Nieder <jrnieder@gmail.com>
- Date
- Oct 9, 2010, 19:54 UTC
- Message-ID
- <20101009195446.GA19064@burratino>
- In-Reply-To
- <4CB0C0DC.40108@web.de>
Jens Lehmann wrote:
> Am 07.10.2010 15:33, schrieb Jon Seymour:
Show 13 quoted lines
>> I wonder if the name is a little too general for the function of this >> configuration variable and if it might not be better to qualify it a >> little further, perhaps >> with the recursive suffix, e.g.: >> >> submodule.<name>.fetch.recursive >> >> This would allow us to define other attributes that configure fetch on >> a per submodule basis later should the need arise. > > I think that's a valid point (especially as we might add the --recursive > option to other commands too). I will change the option name as proposed > in the next version.
That would look like
[submodule "<name>"] fetch.recursive = ...
in files with .git/config syntax. Maybe fetchRecursive or similar would be more consistent with existing variables?
I'm not personally invested in any name; just thought that reminder might be useful.