Re: [PATCH 4/7] gitweb: link heads and remotes view
- From
Jakub Narebski <jnareb@gmail.com>
- Date
- Sep 16, 2010, 23:02 UTC
- Message-ID
- <201009170102.23053.jnareb@gmail.com>
- In-Reply-To
- <1284629465-14798-5-git-send-email-giuseppe.bilotta@gmail.com>
On Thu, 16 Sep 2010, Giuseppe Bilotta wrote:
> Add a link in heads view to remotes view (if the feature is > enabled), and conversely from remotes to heads.
Good idea... but this commit message doesn't tell us *where* this link do appear. It is in lower part (the action specific part) of page navigation menu.
Show 17 quoted lines
> Signed-off-by: Giuseppe Bilotta <giuseppe.bilotta@gmail.com>
> ---
> gitweb/gitweb.perl | 10 ++++++++--
> 1 files changed, 8 insertions(+), 2 deletions(-)
>
> diff --git a/gitweb/gitweb.perl b/gitweb/gitweb.perl
> index 0118739..6138c6e 100755
> --- a/gitweb/gitweb.perl
> +++ b/gitweb/gitweb.perl
> @@ -5511,7 +5511,10 @@ sub git_tags {
> sub git_heads {
> my $head = git_get_head_hash($project);
> git_header_html();
> - git_print_page_nav('','', $head,undef,$head);
> + my $heads_nav = gitweb_check_feature('remote_heads') ?
> + $cgi->a({-href => href(action=>"remotes", -replay=>1)},
> + "remotes") : undef;I think it would be more readable here to use 'if' statement instead of conditional operator.
Show 20 quoted lines
> + git_print_page_nav('','', $head,undef,$head, $heads_nav);
> git_print_header_div('summary', $project);
>
> my @headslist = git_get_heads_list(undef, 'heads');
> @@ -5527,7 +5530,10 @@ sub git_remotes {
>
> my $head = git_get_head_hash($project);
> git_header_html();
> - git_print_page_nav('','', $head,undef,$head);
> + my $heads_nav =
> + $cgi->a({-href => href(action=>"heads", -replay=>1)},
> + "heads");
> + git_print_page_nav('','', $head,undef,$head, $heads_nav);
> git_print_header_div('summary', $project);
>
> my @remotelist = git_get_heads_list(undef, 'remotes');
> --
> 1.7.3.rc1.230.g8b572
>
> -- Jakub Narebski Poland