Re: [PATCH] send-email: do not check for editor until needed
- From
Jonathan Nieder <jrnieder@gmail.com>
- Date
- Mar 23, 2010, 19:25 UTC
- Message-ID
- <20100323192557.GA1511@progeny.tock>
- In-Reply-To
- <A612847CFE53224C91B23E3A5B48BAC73EC0B01EE8@xmail3.se.axis.com>
Peter Kjellerstedt wrote:
Show 9 quoted lines
> Shouldn't that be:
>
> if ($#_ == -1) {
> return;
> }
>
> or more readable:
>
> return if (!@_);Probably. :)
> as I assume you are trying to protect do_edit() from being called > without arguments?
I tested out Michael J Gruber’s simpler patch and it both makes sense and works fine, so I’d suggest going with it instead.
Still, thanks for the comments. It is good to know what I need to learn.
Regards, Jonathan