Re: [EGIT PATCH 02/10] Rename the objectsUrl in the nested HttpObjectDB to
- From
Shawn O. Pearce <spearce@spearce.org>
- Date
- Mar 16, 2009, 20:25 UTC
- Message-ID
- <20090316202513.GS22920@spearce.org>
- In-Reply-To
- <1237234483-3405-3-git-send-email-robin.rosenberg@dewire.com>
Robin Rosenberg <robin.rosenberg@dewire.com> wrote:
> It is used for looking at alternate objects, so name it such
No SOB?
But I disagree with this name change. Its pointing at the objects directory of a repository. It may also be used to point at an alternate when opening an alternate, in which case it points at the alternate's objects directory.
IMHO, objectsUrl is the right name for this.
Show 14 quoted lines
> ---
> .../org/spearce/jgit/transport/TransportHttp.java | 14 +++++++-------
> 1 files changed, 7 insertions(+), 7 deletions(-)
>
> diff --git a/org.spearce.jgit/src/org/spearce/jgit/transport/TransportHttp.java b/org.spearce.jgit/src/org/spearce/jgit/transport/TransportHttp.java
> index fe4a437..38d26b3 100644
> --- a/org.spearce.jgit/src/org/spearce/jgit/transport/TransportHttp.java
> +++ b/org.spearce.jgit/src/org/spearce/jgit/transport/TransportHttp.java
> @@ -112,15 +112,15 @@ public void close() {
> }
>
> class HttpObjectDB extends WalkRemoteObjectDatabase {
> - private final URL objectsUrl;
> + private final URL alternateObjectsUrl;-- Shawn.