git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[EGIT PATCH 06/10] Rename the gitDir fields to indicate they refer to another dir than the default

From
Robin Rosenberg <robin.rosenberg@dewire.com>
Date
Mar 16, 2009, 20:14 UTC
Message-ID
<1237234483-3405-7-git-send-email-robin.rosenberg@dewire.com>
In-Reply-To
<1237234483-3405-6-git-send-email-robin.rosenberg@dewire.com>
---
 .../src/org/spearce/jgit/pgm/ReceivePack.java      |   10 +++++-----
 .../src/org/spearce/jgit/pgm/UploadPack.java       |   10 +++++-----
 2 files changed, 10 insertions(+), 10 deletions(-)
diff --git a/org.spearce.jgit.pgm/src/org/spearce/jgit/pgm/ReceivePack.java b/org.spearce.jgit.pgm/src/org/spearce/jgit/pgm/ReceivePack.java
index 579f893..7c72e2c 100644
--- a/org.spearce.jgit.pgm/src/org/spearce/jgit/pgm/ReceivePack.java
+++ b/org.spearce.jgit.pgm/src/org/spearce/jgit/pgm/ReceivePack.java
@@ -45,7 +45,7 @@
 @Command(common = false, usage = "Server side backend for 'jgit push'")
 class ReceivePack extends TextBuiltin {
 	@Argument(index = 0, required = true, metaVar = "DIRECTORY", usage = "Repository to receive into")
-	File gitdir;
+	File newGitdir;
 
 	@Override
 	protected final boolean requiresRepository() {
@@ -56,11 +56,11 @@ protected final boolean requiresRepository() {
 	protected void run() throws Exception {
 		final org.spearce.jgit.transport.ReceivePack rp;
 
-		if (new File(gitdir, ".git").isDirectory())
-			gitdir = new File(gitdir, ".git");
-		db = new Repository(gitdir);
+		if (new File(newGitdir, ".git").isDirectory())
+			newGitdir = new File(newGitdir, ".git");
+		db = new Repository(newGitdir);
 		if (!db.getObjectsDirectory().isDirectory())
-			throw die("'" + gitdir.getPath() + "' not a git repository");
+			throw die("'" + newGitdir.getPath() + "' not a git repository");
 		rp = new org.spearce.jgit.transport.ReceivePack(db);
 		rp.receive(System.in, System.out, System.err);
 	}
diff --git a/org.spearce.jgit.pgm/src/org/spearce/jgit/pgm/UploadPack.java b/org.spearce.jgit.pgm/src/org/spearce/jgit/pgm/UploadPack.java
index d6f6d7c..b9e25d0 100644
--- a/org.spearce.jgit.pgm/src/org/spearce/jgit/pgm/UploadPack.java
+++ b/org.spearce.jgit.pgm/src/org/spearce/jgit/pgm/UploadPack.java
@@ -45,7 +45,7 @@
 @Command(common = false, usage = "Server side backend for 'jgit fetch'")
 class UploadPack extends TextBuiltin {
 	@Argument(index = 0, required = true, metaVar = "DIRECTORY", usage = "Repository to read from")
-	File gitdir;
+	File newGitdir;
 
 	@Override
 	protected final boolean requiresRepository() {
@@ -56,11 +56,11 @@ protected final boolean requiresRepository() {
 	protected void run() throws Exception {
 		final org.spearce.jgit.transport.UploadPack rp;
 
-		if (new File(gitdir, ".git").isDirectory())
-			gitdir = new File(gitdir, ".git");
-		db = new Repository(gitdir);
+		if (new File(newGitdir, ".git").isDirectory())
+			newGitdir = new File(newGitdir, ".git");
+		db = new Repository(newGitdir);
 		if (!db.getObjectsDirectory().isDirectory())
-			throw die("'" + gitdir.getPath() + "' not a git repository");
+			throw die("'" + newGitdir.getPath() + "' not a git repository");
 		rp = new org.spearce.jgit.transport.UploadPack(db);
 		rp.upload(System.in, System.out, System.err);
 	}
-- 
1.6.1.285.g35d8b
Previous: Robin RosenbergNext: Robin Rosenberg
Message 7 of 15 in “JGit cleanups”
  1. 00/10 JGit cleanupsRobin Rosenberg, Mar 16, 2009
  2. 01/10 Require javadoc on protected methods in jgit coreRobin Rosenberg, Mar 16, 2009
  3. 02/10 Rename the objectsUrl in the nested HttpObjectDB toRobin Rosenberg, Mar 16, 2009
  4. 03/10 Rename variables that hides others with different content in FetchProcessRobin Rosenberg, Mar 16, 2009
  5. 04/10 Rename a parameter i PackWriter that hides another with the same nameRobin Rosenberg, Mar 16, 2009
  6. 05/10 Rename fields to avoid hiding of field names in ReadTreeTestRobin Rosenberg, Mar 16, 2009
  7. 06/10 Rename the gitDir fields to indicate they refer to another dir than the defaultRobin Rosenberg, Mar 16, 2009
  8. 07/10 Rename a parameter in PushProcessTest that hides anotherRobin Rosenberg, Mar 16, 2009
  9. 08/10 Drop unused end parameters in hunk parsing codeRobin Rosenberg, Mar 16, 2009
  10. 09/10 Drop unused File arguments in IndexTreeWalker and WorkdirCheckoutRobin Rosenberg, Mar 16, 2009
  11. 10/10 Drop an effectively unused parameter in IndexTreeWalker.Robin Rosenberg, Mar 16, 2009
  12. Shawn O. PearceMar 16, 2009
  13. Shawn O. PearceMar 16, 2009
  14. Robin RosenbergMar 16, 2009
  15. Shawn O. PearceMar 16, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.