git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[EGIT PATCH 00/10] JGit cleanups

From
Robin Rosenberg <robin.rosenberg@dewire.com>
Date
Mar 16, 2009, 20:14 UTC
Message-ID
<1237234483-3405-1-git-send-email-robin.rosenberg@dewire.com>

Getting annoyed with all the noise I came up with series of cleanups. The hunk parsing fixes are the one's I'm not really sure about, but my attempts to find a case that would give an uncontrolled error did not find much success.

-- robin
Robin Rosenberg (10):
  Require javadoc on protected methods in jgit core
  Rename the objectsUrl in the nested HttpObjectDB to
  Rename variables that hides others with different content in
    FetchProcess
  Rename a parameter i PackWriter that hides another with the same name
  Rename fields to avoid hiding of field names in ReadTreeTest
  Rename the gitDir fields to indicate they refer to another dir than
    the default
  Rename a parameter in PushProcessTest that hides another
  Drop unused end parameters in hunk parsing code
  Drop unused File arguments in IndexTreeWalker and WorkdirCheckout
  Drop an effectively unused parameter in IndexTreeWalker.
 .../.settings/org.eclipse.jdt.core.prefs           |    7 +-
 .../src/org/spearce/jgit/pgm/ReceivePack.java      |   10 +-
 .../src/org/spearce/jgit/pgm/TextBuiltin.java      |    9 +-
 .../src/org/spearce/jgit/pgm/UploadPack.java       |   10 +-
 .../tst/org/spearce/jgit/lib/ReadTreeTest.java     |  118 ++++++++++----------
 .../spearce/jgit/transport/PushProcessTest.java    |    4 +-
 .../.settings/org.eclipse.jdt.core.prefs           |    5 +-
 .../jgit/dircache/DirCacheBuildIterator.java       |    2 +-
 .../spearce/jgit/dircache/DirCacheIterator.java    |    2 +-
 .../src/org/spearce/jgit/lib/IndexTreeWalker.java  |   12 +-
 .../src/org/spearce/jgit/lib/ObjectId.java         |    2 +-
 .../src/org/spearce/jgit/lib/PackIndex.java        |    6 +-
 .../src/org/spearce/jgit/lib/PackWriter.java       |    8 +-
 .../jgit/lib/TreeVisitorWithCurrentDirectory.java  |    4 +-
 .../src/org/spearce/jgit/lib/WorkDirCheckout.java  |   17 ++--
 .../org/spearce/jgit/merge/StrategyOneSided.java   |    2 +-
 .../org/spearce/jgit/patch/CombinedHunkHeader.java |    2 +-
 .../src/org/spearce/jgit/patch/FileHeader.java     |   18 ++--
 .../src/org/spearce/jgit/patch/HunkHeader.java     |    6 +-
 .../src/org/spearce/jgit/patch/Patch.java          |    8 +-
 .../org/spearce/jgit/revplot/PlotCommitList.java   |    9 ++
 .../src/org/spearce/jgit/revplot/PlotWalk.java     |    4 +
 .../org/spearce/jgit/transport/DaemonService.java  |    4 +-
 .../org/spearce/jgit/transport/FetchProcess.java   |    8 +-
 .../org/spearce/jgit/transport/OpenSshConfig.java  |    2 +-
 .../spearce/jgit/transport/OperationResult.java    |   10 +-
 .../spearce/jgit/transport/PackedObjectInfo.java   |    2 +-
 .../src/org/spearce/jgit/transport/PushResult.java |    2 +-
 .../spearce/jgit/transport/RemoteRefUpdate.java    |    6 +-
 .../org/spearce/jgit/transport/TransportHttp.java  |   14 +-
 .../spearce/jgit/treewalk/WorkingTreeIterator.java |    7 +
 31 files changed, 173 insertions(+), 147 deletions(-)
Next: Robin Rosenberg
Message 1 of 15 in “JGit cleanups”
  1. 00/10 JGit cleanupsRobin Rosenberg, Mar 16, 2009
  2. 01/10 Require javadoc on protected methods in jgit coreRobin Rosenberg, Mar 16, 2009
  3. 02/10 Rename the objectsUrl in the nested HttpObjectDB toRobin Rosenberg, Mar 16, 2009
  4. 03/10 Rename variables that hides others with different content in FetchProcessRobin Rosenberg, Mar 16, 2009
  5. 04/10 Rename a parameter i PackWriter that hides another with the same nameRobin Rosenberg, Mar 16, 2009
  6. 05/10 Rename fields to avoid hiding of field names in ReadTreeTestRobin Rosenberg, Mar 16, 2009
  7. 06/10 Rename the gitDir fields to indicate they refer to another dir than the defaultRobin Rosenberg, Mar 16, 2009
  8. 07/10 Rename a parameter in PushProcessTest that hides anotherRobin Rosenberg, Mar 16, 2009
  9. 08/10 Drop unused end parameters in hunk parsing codeRobin Rosenberg, Mar 16, 2009
  10. 09/10 Drop unused File arguments in IndexTreeWalker and WorkdirCheckoutRobin Rosenberg, Mar 16, 2009
  11. 10/10 Drop an effectively unused parameter in IndexTreeWalker.Robin Rosenberg, Mar 16, 2009
  12. Shawn O. PearceMar 16, 2009
  13. Shawn O. PearceMar 16, 2009
  14. Robin RosenbergMar 16, 2009
  15. Shawn O. PearceMar 16, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.