git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[EGIT PATCH 10/10] Drop an effectively unused parameter in IndexTreeWalker.

From
Robin Rosenberg <robin.rosenberg@dewire.com>
Date
Mar 16, 2009, 20:14 UTC
Message-ID
<1237234483-3405-11-git-send-email-robin.rosenberg@dewire.com>
In-Reply-To
<1237234483-3405-10-git-send-email-robin.rosenberg@dewire.com>
The value was always the same as the field it shadowed
---
 .../src/org/spearce/jgit/lib/IndexTreeWalker.java  |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/org.spearce.jgit/src/org/spearce/jgit/lib/IndexTreeWalker.java b/org.spearce.jgit/src/org/spearce/jgit/lib/IndexTreeWalker.java
index e2078e1..0f1aef4 100644
--- a/org.spearce.jgit/src/org/spearce/jgit/lib/IndexTreeWalker.java
+++ b/org.spearce.jgit/src/org/spearce/jgit/lib/IndexTreeWalker.java
@@ -126,7 +126,7 @@ private void walk(Tree tree, Tree auxTree) throws IOException {
 			if (pi != null)
 				visitEntry(pm, pa, pi);
 			else
-				finishVisitTree(pm, pa, curIndexPos, root);
+				finishVisitTree(pm, pa, curIndexPos);
 
 			if (pm != null) m = mi.hasNext() ? mi.next() : null;
 			if (pa != null) a = ai.hasNext() ? ai.next() : null;
@@ -160,7 +160,7 @@ else if (t2 != null)
 				visitor.visitEntry(t1, i, f);
 	}
 
-	private void finishVisitTree(TreeEntry t1, TreeEntry t2, int curIndexPos, File root)
+	private void finishVisitTree(TreeEntry t1, TreeEntry t2, int curIndexPos)
 			throws IOException {
 
 		assert t1 != null || t2 != null : "Needs at least one entry";
-- 
1.6.1.285.g35d8b
Previous: Robin RosenbergNext: Shawn O. Pearce
Message 11 of 15 in “JGit cleanups”
  1. 00/10 JGit cleanupsRobin Rosenberg, Mar 16, 2009
  2. 01/10 Require javadoc on protected methods in jgit coreRobin Rosenberg, Mar 16, 2009
  3. 02/10 Rename the objectsUrl in the nested HttpObjectDB toRobin Rosenberg, Mar 16, 2009
  4. 03/10 Rename variables that hides others with different content in FetchProcessRobin Rosenberg, Mar 16, 2009
  5. 04/10 Rename a parameter i PackWriter that hides another with the same nameRobin Rosenberg, Mar 16, 2009
  6. 05/10 Rename fields to avoid hiding of field names in ReadTreeTestRobin Rosenberg, Mar 16, 2009
  7. 06/10 Rename the gitDir fields to indicate they refer to another dir than the defaultRobin Rosenberg, Mar 16, 2009
  8. 07/10 Rename a parameter in PushProcessTest that hides anotherRobin Rosenberg, Mar 16, 2009
  9. 08/10 Drop unused end parameters in hunk parsing codeRobin Rosenberg, Mar 16, 2009
  10. 09/10 Drop unused File arguments in IndexTreeWalker and WorkdirCheckoutRobin Rosenberg, Mar 16, 2009
  11. 10/10 Drop an effectively unused parameter in IndexTreeWalker.Robin Rosenberg, Mar 16, 2009
  12. Shawn O. PearceMar 16, 2009
  13. Shawn O. PearceMar 16, 2009
  14. Robin RosenbergMar 16, 2009
  15. Shawn O. PearceMar 16, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.