Re: [PATCH] Switch receive.denyCurrentBranch to "refuse"
- From
Jeff King <peff@peff.net>
- Date
- Jan 30, 2009, 14:35 UTC
- Message-ID
- <20090130143521.GA31673@coredump.intra.peff.net>
- In-Reply-To
- <alpine.DEB.1.00.0901301421170.3586@pacific.mpi-cbg.de>
On Fri, Jan 30, 2009 at 02:23:02PM +0100, Johannes Schindelin wrote:
Show 12 quoted lines
> > On the other hand, you also missed the boat on receive.denyDeletes and > > receive.denyNonFastForwards. > > The idea with these is that they are _booleans_, and therefore > > [receive] > denyDeletes > > is something natural to write, because "denyDeletes" is _not_ the default. > > However, with denyCurrentBranch we wanted to change the default in the > long run, so I agree it was a not-so-brilliant choice.
Good point. I do agree that allowCurrentBranch would have been a better name, but I don't know that it is worth the pain now of adding new config plus supporting the old name forever.
-Peff