git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v2 2/3][GSOC] diff: use is_dot_or_dotdot() instead of strcmp()

From
Hiroyuki Sano <sh19910711@gmail.com>
Date
Mar 19, 2014, 11:23 UTC
Message-ID
<1395228230-10189-2-git-send-email-sh19910711@gmail.com>
In-Reply-To
<1395228230-10189-1-git-send-email-sh19910711@gmail.com>

The is_dot_or_dotdot() is used to check if the string is either "." or "..". Include the "dir.h" header file to use is_dot_or_dotdot().

Signed-off-by: Hiroyuki Sano <sh19910711@gmail.com>
---
 diff-no-index.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/diff-no-index.c b/diff-no-index.c
index 20b6a8a..8e642b3 100644
--- a/diff-no-index.c
+++ b/diff-no-index.c
@@ -11,6 +11,7 @@
 #include "tag.h"
 #include "diff.h"
 #include "diffcore.h"
+#include "dir.h"
 #include "revision.h"
 #include "log-tree.h"
 #include "builtin.h"
@@ -25,7 +26,7 @@ static int get_path_list(const char *path, struct string_list *list)
 		return error("Could not open directory %s", path);
 
 	while ((e = readdir(dir)))
-		if (strcmp(".", e->d_name) && strcmp("..", e->d_name))
+		if (!is_dot_or_dotdot(e->d_name))
 			string_list_insert(list, e->d_name);
 
 	closedir(dir);
-- 
1.9.0
Previous: Hiroyuki SanoNext: Eric Sunshine
Message 2 of 6 in “[GSOC] diff: rename read_directory() to get_path_list()”
  1. 1/3 [GSOC] diff: rename read_directory() to get_path_list()Hiroyuki Sano, Mar 19, 2014
  2. 2/3 [GSOC] diff: use is_dot_or_dotdot() instead of strcmp()Hiroyuki Sano, Mar 19, 2014
  3. Eric SunshineMar 19, 2014
  4. 3/3 [GSOC] fsck: replace if-statements to logical expressionsHiroyuki Sano, Mar 19, 2014
  5. Junio C HamanoMar 19, 2014
  6. Eric SunshineMar 19, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.