git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 1/3][GSOC] diff: rename read_directory() to get_path_list()

From
Eric Sunshine <sunshine@sunshineco.com>
Date
Mar 19, 2014, 21:15 UTC
Message-ID
<CAPig+cRSh5XoKKBZ6iyAwEvUf90N4Ajfp_459ME3zoBGS2h23Q@mail.gmail.com>
In-Reply-To
<1395228230-10189-1-git-send-email-sh19910711@gmail.com>
On Wed, Mar 19, 2014 at 7:23 AM, Hiroyuki Sano <sh19910711@gmail.com> wrote:
> Subject: diff: rename read_directory() to get_path_list()
You probably mean 'diff-no-index' here rather than 'diff'.
> Including "dir.h" in "diff-no-index.c", it causes a compile error, because
> the same name function read_directory() is declared globally in "dir.h".
It might be a bit clearer to give a hint as to why dir.h will be a problem:
    A subsequent patch will include dir.h in diff-no-index.c,
    however, dir.h declares a read_directory() which is different
    from the one defined statically by diff-no-index.c.
> This change is to avoid conflicts as above.
Good explanation, but write in imperative mood:
    Rename the local read_directory() to avoid the conflict.
Show 33 quoted lines
> Signed-off-by: Hiroyuki Sano <sh19910711@gmail.com>
> ---
>  diff-no-index.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/diff-no-index.c b/diff-no-index.c
> index 8e10bff..20b6a8a 100644
> --- a/diff-no-index.c
> +++ b/diff-no-index.c
> @@ -16,7 +16,7 @@
>  #include "builtin.h"
>  #include "string-list.h"
>
> -static int read_directory(const char *path, struct string_list *list)
> +static int get_path_list(const char *path, struct string_list *list)
>  {
>         DIR *dir;
>         struct dirent *e;
> @@ -107,9 +107,9 @@ static int queue_diff(struct diff_options *o,
>                 int i1, i2, ret = 0;
>                 size_t len1 = 0, len2 = 0;
>
> -               if (name1 && read_directory(name1, &p1))
> +               if (name1 && get_path_list(name1, &p1))
>                         return -1;
> -               if (name2 && read_directory(name2, &p2)) {
> +               if (name2 && get_path_list(name2, &p2)) {
>                         string_list_clear(&p1, 0);
>                         return -1;
>                 }
> --
> 1.9.0
>
Previous: Junio C Hamano
Message 6 of 6 in “[GSOC] diff: rename read_directory() to get_path_list()”
  1. 1/3 [GSOC] diff: rename read_directory() to get_path_list()Hiroyuki Sano, Mar 19, 2014
  2. 2/3 [GSOC] diff: use is_dot_or_dotdot() instead of strcmp()Hiroyuki Sano, Mar 19, 2014
  3. Eric SunshineMar 19, 2014
  4. 3/3 [GSOC] fsck: replace if-statements to logical expressionsHiroyuki Sano, Mar 19, 2014
  5. Junio C HamanoMar 19, 2014
  6. Eric SunshineMar 19, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.