git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 2/3][GSOC] diff: use is_dot_or_dotdot() instead of strcmp()

From
Eric Sunshine <sunshine@sunshineco.com>
Date
Mar 19, 2014, 21:15 UTC
Message-ID
<CAPig+cT5TMHoLDeavsV89Mopgd59rUBFF8QUj68zbX6ZDNZE7g@mail.gmail.com>
In-Reply-To
<1395228230-10189-2-git-send-email-sh19910711@gmail.com>
On Wed, Mar 19, 2014 at 7:23 AM, Hiroyuki Sano <sh19910711@gmail.com> wrote:
> Subject: diff: use is_dot_or_dotdot() instead of strcmp()
You probably meant 'diff-no-index' rather than 'diff'.
You could make the subject a bit more explanatory by saying:
    use is_dot_or_dotdot() instead of a manual "."/".." check
> The is_dot_or_dotdot() is used to check if the string is either "." or "..".

It's pretty obvious what this function does, so it's not necessary to explain it.

> Include the "dir.h" header file to use is_dot_or_dotdot().

Including dir.h is a obvious requirement of using is_dot_or_dotdot(), thus also does not require explanation.

Otherwise, the patch looks fine.
Show 29 quoted lines
> Signed-off-by: Hiroyuki Sano <sh19910711@gmail.com>
> ---
>  diff-no-index.c | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/diff-no-index.c b/diff-no-index.c
> index 20b6a8a..8e642b3 100644
> --- a/diff-no-index.c
> +++ b/diff-no-index.c
> @@ -11,6 +11,7 @@
>  #include "tag.h"
>  #include "diff.h"
>  #include "diffcore.h"
> +#include "dir.h"
>  #include "revision.h"
>  #include "log-tree.h"
>  #include "builtin.h"
> @@ -25,7 +26,7 @@ static int get_path_list(const char *path, struct string_list *list)
>                 return error("Could not open directory %s", path);
>
>         while ((e = readdir(dir)))
> -               if (strcmp(".", e->d_name) && strcmp("..", e->d_name))
> +               if (!is_dot_or_dotdot(e->d_name))
>                         string_list_insert(list, e->d_name);
>
>         closedir(dir);
> --
> 1.9.0
>
Previous: Hiroyuki SanoNext: Hiroyuki Sano
Message 3 of 6 in “[GSOC] diff: rename read_directory() to get_path_list()”
  1. 1/3 [GSOC] diff: rename read_directory() to get_path_list()Hiroyuki Sano, Mar 19, 2014
  2. 2/3 [GSOC] diff: use is_dot_or_dotdot() instead of strcmp()Hiroyuki Sano, Mar 19, 2014
  3. Eric SunshineMar 19, 2014
  4. 3/3 [GSOC] fsck: replace if-statements to logical expressionsHiroyuki Sano, Mar 19, 2014
  5. Junio C HamanoMar 19, 2014
  6. Eric SunshineMar 19, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.