git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v5 00/31] Follow perlcritic's recommandations

From
Célestin Matte <celestin.matte@ensimag.fr>
Date
Jun 12, 2013, 15:43 UTC
Message-ID
<1371051828-12866-1-git-send-email-celestin.matte@ensimag.fr>

Not many changes since v3. This version is only for fixing last typos and applying Junio's recommandations for [21/31], which I forgot in v4. At this point, the only patch worth reviewing is [21/31].

Changes with v4 : 
- fixed typos
- Change in [21/31]: all the processing is done within the subroutine
Changes with v3:
- Remove whitespace in [18/28]
- Typo in [09/28]
- Better line split in [22/28]
- A part of the file @@ -610,9 +610,9 @@ had escaped patches [22/31] and 
[23/31] for some reason. This is fixed.
- patch [29/31] and [30/31] are new: they add a .perlcriticrc file to ignore
some rules and add a rule in the Makefile for perlcritic
- patch [31/31] is also a new one, which intends to make some error messages 
more precise. It comes from an advice from es in the reviewing of v1, that I 
had forgotten to add in earlier versions. It is not related to perlcritic, but I
hope it can be included into this series of patches anyway.
Changes with v2:
- Remove patch [02/22] about using the Readonly module
- Split commit [07/22] into 5 different ones
- Split commit [14/22] into 2 different ones
- Patch [17/22] was *not* split: tell me if it is necessary
- Remove wrong change in patch [22/22]
Changes with v1:
- split first commit into 6 different commits
- remove commit [17/18] about moving open() call
- took every other comment into account
Célestin Matte (31):
  git-remote-mediawiki: Make a regexp clearer
  git-remote-mediawiki: Move "use warnings;" before any instruction
  git-remote-mediawiki: Replace :utf8 by :encoding(UTF-8)
  git-remote-mediawiki: Always end a subroutine with a return
  git-remote-mediawiki: Move a variable declaration at the top of the
    code
  git-remote-mediawiki: Change syntax of map calls
  git-remote-mediawiki: Rewrite unclear line of instructions
  git-remote-mediawiki: Remove useless regexp modifier (m)
  git-remote-mediawiki: Change the behaviour of a split
  git-remote-mediawiki: Change separator of some regexps
  git-remote-mediawiki: Change style in a regexp
  git-remote-mediawiki: Change style in a regexp
  git-remote-mediawiki: Add newline in the end of die() error messages
  git-remote-mediawiki: Change the name of a variable
  git-remote-mediawiki: Turn double-negated expressions into simple
    expressions
  git-remote-mediawiki: Remove unused variable $entry
  git-remote-mediawiki: Rename a variable ($last) which has the name of
    a keyword
  git-remote-mediawiki: Assign a variable as undef and make proper
    indentation
  git-remote-mediawiki: Check return value of open
  git-remote-mediawiki: remove import of unused open2
  git-remote-mediawiki: Put long code into a subroutine
  git-remote-mediawiki: Modify strings for a better coding-style
  git-remote-mediawiki: Brace file handles for print for more clarity
  git-remote-mediawiki: Replace "unless" statements with negated "if"
    statements
  git-remote-mediawiki: Don't use quotes for empty strings
  git-remote-mediawiki: Put non-trivial numeric values in constants.
  git-remote-mediawiki: Fix a typo ("mediwiki" instead of "mediawiki")
  git-remote-mediawiki: Clearly rewrite double dereference
  git-remote-mediawiki: Add a .perlcriticrc file
  git-remote-mediawiki: add a perlcritic rule in Makefile
  git-remote-mediawiki: Make error message more precise
 contrib/mw-to-git/.perlcriticrc             |  28 ++
 contrib/mw-to-git/Makefile                  |   5 +-
 contrib/mw-to-git/git-remote-mediawiki.perl | 549 +++++++++++++++-------------
 3 files changed, 328 insertions(+), 254 deletions(-)
 create mode 100644 contrib/mw-to-git/.perlcriticrc
-- 
1.8.3.rc3.18.g21a7b2c
Next: Célestin Matte
Message 1 of 39 in “Follow perlcritic's recommandations”
  1. 00/31 Follow perlcritic's recommandationsCélestin Matte, Jun 12, 2013
  2. 01/31 git-remote-mediawiki: Make a regexp clearerCélestin Matte, Jun 12, 2013
  3. 02/31 git-remote-mediawiki: Move "use warnings;" before any instructionCélestin Matte, Jun 12, 2013
  4. 03/31 git-remote-mediawiki: Replace :utf8 by :encoding(UTF-8)Célestin Matte, Jun 12, 2013
  5. 04/31 git-remote-mediawiki: Always end a subroutine with a returnCélestin Matte, Jun 12, 2013
  6. 05/31 git-remote-mediawiki: Move a variable declaration at the top of the codeCélestin Matte, Jun 12, 2013
  7. 06/31 git-remote-mediawiki: Change syntax of map callsCélestin Matte, Jun 12, 2013
  8. 07/31 git-remote-mediawiki: Rewrite unclear line of instructionsCélestin Matte, Jun 12, 2013
  9. 08/31 git-remote-mediawiki: Remove useless regexp modifier (m)Célestin Matte, Jun 12, 2013
  10. 09/31 git-remote-mediawiki: Change the behaviour of a splitCélestin Matte, Jun 12, 2013
  11. 10/31 git-remote-mediawiki: Change separator of some regexpsCélestin Matte, Jun 12, 2013
  12. 11/31 git-remote-mediawiki: Change style in a regexpCélestin Matte, Jun 12, 2013
  13. 12/31 git-remote-mediawiki: Change style in a regexpCélestin Matte, Jun 12, 2013
  14. 13/31 git-remote-mediawiki: Add newline in the end of die() error messagesCélestin Matte, Jun 12, 2013
  15. 14/31 git-remote-mediawiki: Change the name of a variableCélestin Matte, Jun 12, 2013
  16. 15/31 git-remote-mediawiki: Turn double-negated expressions into simple expressionsCélestin Matte, Jun 12, 2013
  17. 16/31 git-remote-mediawiki: Remove unused variable $entryCélestin Matte, Jun 12, 2013
  18. 17/31 git-remote-mediawiki: Rename a variable ($last) which has the name of a keywordCélestin Matte, Jun 12, 2013
  19. 18/31 git-remote-mediawiki: Assign a variable as undef and make proper indentationCélestin Matte, Jun 12, 2013
  20. 19/31 git-remote-mediawiki: Check return value of openCélestin Matte, Jun 12, 2013
  21. 20/31 git-remote-mediawiki: remove import of unused open2Célestin Matte, Jun 12, 2013
  22. 21/31 git-remote-mediawiki: Put long code into a subroutineCélestin Matte, Jun 12, 2013
  23. 22/31 git-remote-mediawiki: Modify strings for a better coding-styleCélestin Matte, Jun 12, 2013
  24. 23/31 git-remote-mediawiki: Brace file handles for print for more clarityCélestin Matte, Jun 12, 2013
  25. 24/31 git-remote-mediawiki: Replace "unless" statements with negated "if" statementsCélestin Matte, Jun 12, 2013
  26. 25/31 git-remote-mediawiki: Don't use quotes for empty stringsCélestin Matte, Jun 12, 2013
  27. 26/31 git-remote-mediawiki: Put non-trivial numeric values in constants.Célestin Matte, Jun 12, 2013
  28. 27/31 git-remote-mediawiki: Fix a typo ("mediwiki" instead of "mediawiki")Célestin Matte, Jun 12, 2013
  29. 28/31 git-remote-mediawiki: Clearly rewrite double dereferenceCélestin Matte, Jun 12, 2013
  30. 29/31 git-remote-mediawiki: Add a .perlcriticrc fileCélestin Matte, Jun 12, 2013
  31. 30/31 git-remote-mediawiki: add a perlcritic rule in MakefileCélestin Matte, Jun 12, 2013
  32. 31/31 git-remote-mediawiki: Make error message more preciseCélestin Matte, Jun 12, 2013
  33. Matthieu MoyJun 12, 2013
  34. Célestin MatteJun 12, 2013
  35. Célestin MatteJun 12, 2013
  36. Eric SunshineJun 12, 2013
  37. Matthieu MoyJun 12, 2013
  38. Célestin MatteJun 12, 2013
  39. Junio C HamanoJun 12, 2013

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.