[PATCH 1/3] Rename patch_update_file function to patch_update_pathspec
- From
Wincent Colaiuta <win@wincent.com>
- Date
- Nov 24, 2007, 12:55 UTC
- Message-ID
- <1195908922-88023-2-git-send-email-win@wincent.com>
- In-Reply-To
- <1195908922-88023-1-git-send-email-win@wincent.com>
The patch_update_file function really works on pathspecs, not files, so rename it to reflect its actual purpose.
Signed-off-by: Wincent Colaiuta <win@wincent.com> --- git-add--interactive.perl | 4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/git-add--interactive.perl b/git-add--interactive.perl index e347216..15b2c9f 100755 --- a/git-add--interactive.perl +++ b/git-add--interactive.perl @@ -571,11 +571,11 @@ sub patch_update_cmd { HEADER => $status_head, }, @mods); for (@them) { - patch_update_file($_->{VALUE}); + patch_update_pathspec($_->{VALUE}); } } -sub patch_update_file { +sub patch_update_pathspec { my ($ix, $num); my $path = shift; my ($head, @hunk) = parse_diff($path);
-- 1.5.3.6.1992.gd646-dirty