[PATCH 2/7] Rename patch_update_file function to patch_update_pathspec
- From
Wincent Colaiuta <win@wincent.com>
- Date
- Nov 23, 2007, 19:20 UTC
- Message-ID
- <1195845650-85962-3-git-send-email-win@wincent.com>
- In-Reply-To
- <1195845650-85962-2-git-send-email-win@wincent.com>
The patch_update_file function really works on pathspecs, not files, so rename it to reflect its actual purpose.
Signed-off-by: Wincent Colaiuta <win@wincent.com> --- git-add--interactive.perl | 4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/git-add--interactive.perl b/git-add--interactive.perl index fb1e92a..81575e5 100755 --- a/git-add--interactive.perl +++ b/git-add--interactive.perl @@ -564,10 +564,10 @@ sub patch_update_cmd { IMMEDIATE => 1, HEADER => $status_head, }, @mods); - patch_update_file($it->{VALUE}) if ($it); + patch_update_pathspec($it->{VALUE}) if ($it); } -sub patch_update_file { +sub patch_update_pathspec { my ($ix, $num); my $path = shift; my ($head, @hunk) = parse_diff($path);
-- 1.5.3.6.886.g3364