Re: [PATCH 4/6] add ref_abbrev_matches_full_with_rules()
On Nov 12, 2007, at 8:51 PM, Junio C Hamano wrote:
Show 21 quoted lines
> Steffen Prohaska <prohaska@zib.de> writes:
>
>> +int ref_abbrev_matches_full_with_rules(const char *abbrev_name,
>> const char *full_name, const char **rules)
>> +{
>> + const char **p;
>> + const int abbrev_name_len = strlen(abbrev_name);
>> +
>> + for (p = rules; *p; p++) {
>> + if (!strcmp(full_name, mkpath(*p, abbrev_name_len,
>> abbrev_name))) {
>> + return 1;
>> + }
>> + }
>> +
>> + return 0;
>> +}
>> +
>
> How about calling this simply "ref_abbrev_matches()" or
> "refname_match()" which is even shorter?Yes. As you already did on pu. Thanks for cleaning up.
Steffen