From: Steffen Prohaska Date: Mon, 12 Nov 2007 20:51:16 GMT Subject: Re: [PATCH 4/6] add ref_abbrev_matches_full_with_rules() Message-ID: <03A9B0D0-5B70-47BB-B528-B86CE3FAAD8C@zib.de> In-Reply-To: <7vve872qen.fsf@gitster.siamese.dyndns.org> On Nov 12, 2007, at 8:51 PM, Junio C Hamano wrote: > Steffen Prohaska writes: > >> +int ref_abbrev_matches_full_with_rules(const char *abbrev_name, >> const char *full_name, const char **rules) >> +{ >> + const char **p; >> + const int abbrev_name_len = strlen(abbrev_name); >> + >> + for (p = rules; *p; p++) { >> + if (!strcmp(full_name, mkpath(*p, abbrev_name_len, >> abbrev_name))) { >> + return 1; >> + } >> + } >> + >> + return 0; >> +} >> + > > How about calling this simply "ref_abbrev_matches()" or > "refname_match()" which is even shorter? Yes. As you already did on pu. Thanks for cleaning up. Steffen