threads / patch / 46678

patchAdd t/helper/test-write-cache to .gitignore

Subject: [PATCH] Add t/helper/test-write-cache to .gitignore

## tl;dr

3 messages between Aug 28, 2017 and Sep 20, 2017. Diffs are folded; open one to read it.

replies: 2people: 3as markdown or json

Jonathan Tan· Aug 28, 2017, 20:06 UTC · lore

This new binary was introduced in commit 3921a0b ("perf: add test for writing the index", 2017-08-21), but a .gitignore entry was not added for it. Add that entry.

Signed-off-by: Jonathan Tan <jonathantanmy@google.com>
---
 t/helper/.gitignore | 1 +
 1 file changed, 1 insertion(+)
Show changes to t/helper/.gitignore +1 −0
diff --git a/t/helper/.gitignore b/t/helper/.gitignore
index 721650256..7c9d28a83 100644
--- a/t/helper/.gitignore
+++ b/t/helper/.gitignore
@@ -35,3 +35,4 @@
 /test-svn-fe
 /test-urlmatch-normalization
 /test-wildmatch
+/test-write-cache
-- 
2.14.1.581.gf28d330327-goog
Brandon Williams· Aug 28, 2017, 21:09 UTC · re: Jonathan Tan · lore

Re: [PATCH] Add t/helper/test-write-cache to .gitignore

On 08/28, Jonathan Tan wrote:
Show 5 quoted lines
> This new binary was introduced in commit 3921a0b ("perf: add test for
> writing the index", 2017-08-21), but a .gitignore entry was not added
> for it. Add that entry.
> 
> Signed-off-by: Jonathan Tan <jonathantanmy@google.com>
Looks good to me
Show 16 quoted lines
> ---
>  t/helper/.gitignore | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/t/helper/.gitignore b/t/helper/.gitignore
> index 721650256..7c9d28a83 100644
> --- a/t/helper/.gitignore
> +++ b/t/helper/.gitignore
> @@ -35,3 +35,4 @@
>  /test-svn-fe
>  /test-urlmatch-normalization
>  /test-wildmatch
> +/test-write-cache
> -- 
> 2.14.1.581.gf28d330327-goog
> 
-- 
Brandon Williams
Jonathan Nieder· Sep 20, 2017, 18:47 UTC · re: Brandon Williams · lore

Re: [PATCH] Add t/helper/test-write-cache to .gitignore

Brandon Williams wrote:
> On 08/28, Jonathan Tan wrote:
Show 7 quoted lines
>> This new binary was introduced in commit 3921a0b ("perf: add test for
>> writing the index", 2017-08-21), but a .gitignore entry was not added
>> for it. Add that entry.
>>
>> Signed-off-by: Jonathan Tan <jonathantanmy@google.com>
>
> Looks good to me
Reviewed-by: Jonathan Nieder <jrnieder@gmail.com>
as well.
I wonder if we can automate this a little.  Some thoughts:
 A. We could include a test that all the binaries named in
    TEST_PROGRAMS_NEED_X are also named in t/helper/.gitignore.  That
    way tests would fail if this ever falls out of date again.
 B. Even better would be if we could have /t/helper/test-* in
    .gitignore.  E.g. if we rename test-*.c to *.c (e.g.
    t/helper/ctype.c instead of t/helper/test-ctype.c), then the test
    helper source file names would be easier to type and maintaining
    this .gitignore would become a problem of the past.

What do you think? Jonathan

← back to recent threads