Re: [PATCH] Add t/helper/test-write-cache to .gitignore
- From
Jonathan Nieder <jrnieder@gmail.com>
- Date
- Sep 20, 2017, 18:47 UTC
- Message-ID
- <20170920184753.GC27425@aiede.mtv.corp.google.com>
- In-Reply-To
- <20170828210939.GA71562@google.com>
Brandon Williams wrote:
> On 08/28, Jonathan Tan wrote:
Show 7 quoted lines
>> This new binary was introduced in commit 3921a0b ("perf: add test for
>> writing the index", 2017-08-21), but a .gitignore entry was not added
>> for it. Add that entry.
>>
>> Signed-off-by: Jonathan Tan <jonathantanmy@google.com>
>
> Looks good to meReviewed-by: Jonathan Nieder <jrnieder@gmail.com> as well.
I wonder if we can automate this a little. Some thoughts:
A. We could include a test that all the binaries named in
TEST_PROGRAMS_NEED_X are also named in t/helper/.gitignore. That
way tests would fail if this ever falls out of date again. B. Even better would be if we could have /t/helper/test-* in
.gitignore. E.g. if we rename test-*.c to *.c (e.g.
t/helper/ctype.c instead of t/helper/test-ctype.c), then the test
helper source file names would be easier to type and maintaining
this .gitignore would become a problem of the past.What do you think? Jonathan