threads / patch / 34577

patchRename advice.object_name_warning to objectNameWarning

Subject: [PATCH] Rename advice.object_name_warning to objectNameWarning

## tl;dr

2 messages between Jul 31, 2013 and Jul 31, 2013. Diffs are folded; open one to read it.

replies: 1people: 2as markdown or json

Thomas Rast· Jul 31, 2013, 20:23 UTC · lore
We spell config variables in camelCase instead of with_underscores.
Signed-off-by: Thomas Rast <trast@inf.ethz.ch>
---

I figure since we don't have the variable in any release yet *and* the worst possible outcome is that someone sees the advice message again, the consistency is worth the change.

 advice.c    | 2 +-
 sha1_name.c | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
Show changes to 2 files +2 −2

advice.c, sha1_name.c

diff --git a/advice.c b/advice.c
index 2a52098..3eca9f5 100644
--- a/advice.c
+++ b/advice.c
@@ -35,7 +35,7 @@
 	{ "implicitidentity", &advice_implicit_identity },
 	{ "detachedhead", &advice_detached_head },
 	{ "setupstreamfailure", &advice_set_upstream_failure },
-	{ "object_name_warning", &advice_object_name_warning },
+	{ "objectnamewarning", &advice_object_name_warning },
 	{ "rmhints", &advice_rm_hints },
 
 	/* make this an alias for backward compatibility */
diff --git a/sha1_name.c b/sha1_name.c
index 1d210e3..852dd95 100644
--- a/sha1_name.c
+++ b/sha1_name.c
@@ -445,7 +445,7 @@ static int get_sha1_basic(const char *str, int len, unsigned char *sha1)
 	"\n"
 	"where \"$br\" is somehow empty and a 40-hex ref is created. Please\n"
 	"examine these refs and maybe delete them. Turn this message off by\n"
-	"running \"git config advice.object_name_warning false\"");
+	"running \"git config advice.objectNameWarning false\"");
 	unsigned char tmp_sha1[20];
 	char *real_ref = NULL;
 	int refs_found = 0;
-- 
1.8.4.rc0.408.gad6868d
Junio C Hamano· Jul 31, 2013, 22:19 UTC · re: Thomas Rast · lore

Re: [PATCH] Rename advice.object_name_warning to objectNameWarning

Thomas Rast <trast@inf.ethz.ch> writes:
Show 8 quoted lines
> We spell config variables in camelCase instead of with_underscores.
>
> Signed-off-by: Thomas Rast <trast@inf.ethz.ch>
> ---
>
> I figure since we don't have the variable in any release yet *and* the
> worst possible outcome is that someone sees the advice message again,
> the consistency is worth the change.
Thanks, I agree.
Show 31 quoted lines
>
>  advice.c    | 2 +-
>  sha1_name.c | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/advice.c b/advice.c
> index 2a52098..3eca9f5 100644
> --- a/advice.c
> +++ b/advice.c
> @@ -35,7 +35,7 @@
>  	{ "implicitidentity", &advice_implicit_identity },
>  	{ "detachedhead", &advice_detached_head },
>  	{ "setupstreamfailure", &advice_set_upstream_failure },
> -	{ "object_name_warning", &advice_object_name_warning },
> +	{ "objectnamewarning", &advice_object_name_warning },
>  	{ "rmhints", &advice_rm_hints },
>  
>  	/* make this an alias for backward compatibility */
> diff --git a/sha1_name.c b/sha1_name.c
> index 1d210e3..852dd95 100644
> --- a/sha1_name.c
> +++ b/sha1_name.c
> @@ -445,7 +445,7 @@ static int get_sha1_basic(const char *str, int len, unsigned char *sha1)
>  	"\n"
>  	"where \"$br\" is somehow empty and a 40-hex ref is created. Please\n"
>  	"examine these refs and maybe delete them. Turn this message off by\n"
> -	"running \"git config advice.object_name_warning false\"");
> +	"running \"git config advice.objectNameWarning false\"");
>  	unsigned char tmp_sha1[20];
>  	char *real_ref = NULL;
>  	int refs_found = 0;

← back to recent threads