git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] Rename advice.object_name_warning to objectNameWarning

From
Junio C Hamano <gitster@pobox.com>
Date
Jul 31, 2013, 22:19 UTC
Message-ID
<7vmwp2tls0.fsf@alter.siamese.dyndns.org>
In-Reply-To
<bc52a7d4a5f1010e6813ddf503a0b84976dc55e4.1375301985.git.trast@inf.ethz.ch>
Thomas Rast <trast@inf.ethz.ch> writes:
Show 8 quoted lines
> We spell config variables in camelCase instead of with_underscores.
>
> Signed-off-by: Thomas Rast <trast@inf.ethz.ch>
> ---
>
> I figure since we don't have the variable in any release yet *and* the
> worst possible outcome is that someone sees the advice message again,
> the consistency is worth the change.
Thanks, I agree.
Show 31 quoted lines
>
>  advice.c    | 2 +-
>  sha1_name.c | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/advice.c b/advice.c
> index 2a52098..3eca9f5 100644
> --- a/advice.c
> +++ b/advice.c
> @@ -35,7 +35,7 @@
>  	{ "implicitidentity", &advice_implicit_identity },
>  	{ "detachedhead", &advice_detached_head },
>  	{ "setupstreamfailure", &advice_set_upstream_failure },
> -	{ "object_name_warning", &advice_object_name_warning },
> +	{ "objectnamewarning", &advice_object_name_warning },
>  	{ "rmhints", &advice_rm_hints },
>  
>  	/* make this an alias for backward compatibility */
> diff --git a/sha1_name.c b/sha1_name.c
> index 1d210e3..852dd95 100644
> --- a/sha1_name.c
> +++ b/sha1_name.c
> @@ -445,7 +445,7 @@ static int get_sha1_basic(const char *str, int len, unsigned char *sha1)
>  	"\n"
>  	"where \"$br\" is somehow empty and a 40-hex ref is created. Please\n"
>  	"examine these refs and maybe delete them. Turn this message off by\n"
> -	"running \"git config advice.object_name_warning false\"");
> +	"running \"git config advice.objectNameWarning false\"");
>  	unsigned char tmp_sha1[20];
>  	char *real_ref = NULL;
>  	int refs_found = 0;
Previous: Thomas Rast
Message 2 of 2 in “Rename advice.object_name_warning to objectNameWarning”
  1. Rename advice.object_name_warning to objectNameWarningThomas Rast, Jul 31, 2013
  2. Junio C HamanoJul 31, 2013

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.