{"thread":{"id":"34577","subject":"[PATCH] Rename advice.object_name_warning to objectNameWarning","startedAt":"2013-07-31T20:23:31Z","lastAt":"2013-07-31T22:19:43Z","messageCount":2,"participants":["Thomas Rast","Junio C Hamano"],"isPatch":true,"patchVersion":1,"patchTotal":null},"messages":[{"id":"224385","messageId":"bc52a7d4a5f1010e6813ddf503a0b84976dc55e4.1375301985.git.trast@inf.ethz.ch","threadId":"34577","inReplyTo":null,"subject":"[PATCH] Rename advice.object_name_warning to objectNameWarning","fromName":"Thomas Rast","fromEmail":"trast@inf.ethz.ch","sentAt":"2013-07-31T20:23:31Z","receivedAt":"2013-07-31T20:23:31Z","isPatch":true,"sender":{"key":"tr@thomasrast.ch","avatar":"https://avatars.githubusercontent.com/u/153510?v=4"},"body":"We spell config variables in camelCase instead of with_underscores.\n\nSigned-off-by: Thomas Rast <trast@inf.ethz.ch>\n---\n\nI figure since we don't have the variable in any release yet *and* the\nworst possible outcome is that someone sees the advice message again,\nthe consistency is worth the change.\n\n\n advice.c    | 2 +-\n sha1_name.c | 2 +-\n 2 files changed, 2 insertions(+), 2 deletions(-)\n\ndiff --git a/advice.c b/advice.c\nindex 2a52098..3eca9f5 100644\n--- a/advice.c\n+++ b/advice.c\n@@ -35,7 +35,7 @@\n \t{ \"implicitidentity\", &advice_implicit_identity },\n \t{ \"detachedhead\", &advice_detached_head },\n \t{ \"setupstreamfailure\", &advice_set_upstream_failure },\n-\t{ \"object_name_warning\", &advice_object_name_warning },\n+\t{ \"objectnamewarning\", &advice_object_name_warning },\n \t{ \"rmhints\", &advice_rm_hints },\n \n \t/* make this an alias for backward compatibility */\ndiff --git a/sha1_name.c b/sha1_name.c\nindex 1d210e3..852dd95 100644\n--- a/sha1_name.c\n+++ b/sha1_name.c\n@@ -445,7 +445,7 @@ static int get_sha1_basic(const char *str, int len, unsigned char *sha1)\n \t\"\\n\"\n \t\"where \\\"$br\\\" is somehow empty and a 40-hex ref is created. Please\\n\"\n \t\"examine these refs and maybe delete them. Turn this message off by\\n\"\n-\t\"running \\\"git config advice.object_name_warning false\\\"\");\n+\t\"running \\\"git config advice.objectNameWarning false\\\"\");\n \tunsigned char tmp_sha1[20];\n \tchar *real_ref = NULL;\n \tint refs_found = 0;\n-- \n1.8.4.rc0.408.gad6868d\n"},{"id":"224402","messageId":"7vmwp2tls0.fsf@alter.siamese.dyndns.org","threadId":"34577","inReplyTo":"bc52a7d4a5f1010e6813ddf503a0b84976dc55e4.1375301985.git.trast@inf.ethz.ch","subject":"Re: [PATCH] Rename advice.object_name_warning to objectNameWarning","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2013-07-31T22:19:43Z","receivedAt":"2013-07-31T22:19:43Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Thomas Rast <trast@inf.ethz.ch> writes:\n\n> We spell config variables in camelCase instead of with_underscores.\n>\n> Signed-off-by: Thomas Rast <trast@inf.ethz.ch>\n> ---\n>\n> I figure since we don't have the variable in any release yet *and* the\n> worst possible outcome is that someone sees the advice message again,\n> the consistency is worth the change.\n\nThanks, I agree.\n>\n>  advice.c    | 2 +-\n>  sha1_name.c | 2 +-\n>  2 files changed, 2 insertions(+), 2 deletions(-)\n>\n> diff --git a/advice.c b/advice.c\n> index 2a52098..3eca9f5 100644\n> --- a/advice.c\n> +++ b/advice.c\n> @@ -35,7 +35,7 @@\n>  \t{ \"implicitidentity\", &advice_implicit_identity },\n>  \t{ \"detachedhead\", &advice_detached_head },\n>  \t{ \"setupstreamfailure\", &advice_set_upstream_failure },\n> -\t{ \"object_name_warning\", &advice_object_name_warning },\n> +\t{ \"objectnamewarning\", &advice_object_name_warning },\n>  \t{ \"rmhints\", &advice_rm_hints },\n>  \n>  \t/* make this an alias for backward compatibility */\n> diff --git a/sha1_name.c b/sha1_name.c\n> index 1d210e3..852dd95 100644\n> --- a/sha1_name.c\n> +++ b/sha1_name.c\n> @@ -445,7 +445,7 @@ static int get_sha1_basic(const char *str, int len, unsigned char *sha1)\n>  \t\"\\n\"\n>  \t\"where \\\"$br\\\" is somehow empty and a 40-hex ref is created. Please\\n\"\n>  \t\"examine these refs and maybe delete them. Turn this message off by\\n\"\n> -\t\"running \\\"git config advice.object_name_warning false\\\"\");\n> +\t\"running \\\"git config advice.objectNameWarning false\\\"\");\n>  \tunsigned char tmp_sha1[20];\n>  \tchar *real_ref = NULL;\n>  \tint refs_found = 0;\n"}]}