threads / discuss / 26025

Please pull gitk.git master branch

Subject: Please pull gitk.git master branch

## tl;dr

11 messages between Dec 12, 2010 and Dec 14, 2010.

replies: 10people: 5as markdown or json

Paul Mackerras· Dec 12, 2010, 06:31 UTC · lore
Junio,
Please do a pull from
git://git.kernel.org/pub/scm/gitk/gitk.git
to get the commits listed below.

Thanks, Paul.

 gitk        |   81 +++-
 po/pt_BR.po | 1277 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 po/sv.po    |  601 ++++++++++++++--------------
 3 files changed, 1654 insertions(+), 305 deletions(-)
 create mode 100644 po/pt_BR.po
Alexandre Erwin Ittner (1):
      gitk: Add Brazilian Portuguese (pt-BR) translation
Kirill Smelkov (1):
      gitk: Show notes by default (like git log does)
Peter Krefting (1):
      gitk: Update Swedish translation (290t)
Stefan Haller (2):
      gitk: Prevent the text pane from becoming editable
      gitk: Make text selectable on Mac
Thomas Rast (1):
      gitk: Add the equivalent of diff --color-words
Junio C Hamano· Dec 13, 2010, 03:11 UTC · re: Junio C Hamano · lore

Re: Please pull gitk.git master branch

Junio C Hamano <gitster@pobox.com> writes:
> Thanks, pulled (not yet pushed out).
Yikes.

Paul, has this ever been install-tested before you accepted the "pt-BR" patch to your repository?

"msgfmt --tcl" produces po/pt_br.msg for me, but the Makefile wants to install po/pt_BR.msg and fails. Perhaps the poor-man's po2msg.sh does not have this glitch and produces po/pt_BR.msg, but I don't think that is an excuse for not checking with both that script and the real msgfmt before the change gets this far.

Using the -o option on the msgfmt command line to force the command to generate pt_BR.msg fails with:

    msgfmt: --tcl and --output-file are mutually exclusive

Combined with this and the fact that msgfmt produces po/pt_br.msg out of the input po/pt_BR.po makes me suspect that Tcl runtime enviornment does not actually expect pt_BR.msg but want to see the country part downcased. In which case we may need to fix po2msg.sh to match that behaviour.

An workaround would be to rename po/pt_BR.po to po/pt_br.po but I don't know if there are unexpected side effects if we did that.

I'd like to see this glitch sorted out before I push out the result of the merge, so it is likely there won't be a pushout tonight. We need to know:

 * Is this "downcase the country part for --tcl" a bug in the particular
   version of msgfmt I happen to have (it is 0.17 from GNU gettext on
   Debian), or is it the filename convention expected by the Tcl i18n
   runtime environment to have both language and country in lowercase?
 * What is the recommended best practice in Tcl i18n community for naming
   lang_COUNTRY.po file?  Do people typically spell the COUNTRY in
   uppercase and let "msgfmt --tcl" downcase, and deal with the filename
   case issues in the Makefile themselves?  This feels yucky, as it means
   that we cannot use '%.msg : %.po' dependency pattern, but need to list
   the dependencies by hand.  Or do they spell country part in lowercase
   to avoid this whole issue?

My _preferred_ outcome is to see that naming the input "po/pt_br.po" and using the output "po/pt_br.msg" is the BCP, but I'd like somebody to find out what the accepted practice would be in the Tcl land first.

Junio C Hamano· Dec 13, 2010, 07:40 UTC · re: Junio C Hamano · lore

Re: Please pull gitk.git master branch

Junio C Hamano <gitster@pobox.com> writes:
> My _preferred_ outcome is to see that naming the input "po/pt_br.po" and
> using the output "po/pt_br.msg" is the BCP, but I'd like somebody to find
> out what the accepted practice would be in the Tcl land first.

I still don't know what the BCP is in the Tcl community (didn't have time to check, dealing with other topics), but I'll tentatively apply this on top of queue Alexandre's patch and merge the result in 'pu'.

-- >8 --
From: Junio C Hamano <gitster@pobox.com>
Date: Sun, 12 Dec 2010 23:27:21 -0800
Subject: [PATCH] Rename po/pt_BR.po to po/pt_br.po

The "msgfmt --tcl pt_BR.po" (at least on my box, GNU gettext 0.17) command generates pt_BR.msg, i.e. the country part gets downcased. The resulting runtime (i.e. Tcl i18n) happily reads from pt_br.msg when run with the runtime locale set with LANG=pt_BR and/or LC_ALL=pt_BR so it seems to be the expected behaviour.

However, we seem to expect that the resulting file to be named pt_BR.msg, and try to generate and install it.

Currently our Makefile uses $(wildcard po/*.po) to grab the source PO files, expects them to produce $(subst .po,.msg,$(ALL_POFILES)), and its dependency rule is set to use "%.msg : %.po" pattern, all of which need to be adjusted with downcasing from po to msg files; the poor-man's msgfmt script also needs to learn the same downcasing.

Compared to that, renaming the input file to use lowercase countryname throughout the toolchain seems to be a lot cleaner solution to this glitch.

Signed-off-by: Junio C Hamano <gitster@pobox.com>
---
 po/{pt_BR.po => pt_br.po} |    0
 1 files changed, 0 insertions(+), 0 deletions(-)
 rename po/{pt_BR.po => pt_br.po} (100%)
diff --git a/po/pt_BR.po b/po/pt_br.po
similarity index 100%
rename from po/pt_BR.po
rename to po/pt_br.po
Sverre Rabbelier· Dec 13, 2010, 08:36 UTC · re: Junio C Hamano · lore

Re: Please pull gitk.git master branch

Heya,
On Mon, Dec 13, 2010 at 08:40, Junio C Hamano <gitster@pobox.com> wrote:
Show 7 quoted lines
>> My _preferred_ outcome is to see that naming the input "po/pt_br.po" and
>> using the output "po/pt_br.msg" is the BCP, but I'd like somebody to find
>> out what the accepted practice would be in the Tcl land first.
>
> I still don't know what the BCP is in the Tcl community (didn't have time
> to check, dealing with other topics), but I'll tentatively apply this on
> top of queue Alexandre's patch and merge the result in 'pu'.

Pardon my ignorance, what is BCP? None of the definitions I could find seemed likely.

-- 
Cheers,

Sverre Rabbelier
Andreas Ericsson· Dec 13, 2010, 09:25 UTC · re: Sverre Rabbelier · lore

Re: Please pull gitk.git master branch

On 12/13/2010 09:36 AM, Sverre Rabbelier wrote:
Show 14 quoted lines
> Heya,
> 
> On Mon, Dec 13, 2010 at 08:40, Junio C Hamano<gitster@pobox.com>  wrote:
>>> My _preferred_ outcome is to see that naming the input "po/pt_br.po" and
>>> using the output "po/pt_br.msg" is the BCP, but I'd like somebody to find
>>> out what the accepted practice would be in the Tcl land first.
>>
>> I still don't know what the BCP is in the Tcl community (didn't have time
>> to check, dealing with other topics), but I'll tentatively apply this on
>> top of queue Alexandre's patch and merge the result in 'pu'.
> 
> Pardon my ignorance, what is BCP? None of the definitions I could find
> seemed likely.
> 
Best Coding Practice.
-- 
Andreas Ericsson                   andreas.ericsson@op5.se
OP5 AB                             www.op5.se
Tel: +46 8-230225                  Fax: +46 8-230231

Considering the successes of the wars on alcohol, poverty, drugs and
terror, I think we should give some serious thought to declaring war
on peace.
Andreas Schwab· Dec 13, 2010, 19:52 UTC · re: Sverre Rabbelier · lore

Re: Please pull gitk.git master branch

Sverre Rabbelier <srabbelier@gmail.com> writes:
> Pardon my ignorance, what is BCP? None of the definitions I could find
> seemed likely.
http://en.wikipedia.org/wiki/Best_Current_Practice
Andreas.
-- 
Andreas Schwab, schwab@linux-m68k.org
GPG Key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276 4ED5
"And now for something completely different."
Paul Mackerras· Dec 13, 2010, 21:03 UTC · re: Junio C Hamano · lore

Re: Please pull gitk.git master branch

On Sun, Dec 12, 2010 at 11:40:51PM -0800, Junio C Hamano wrote:
Show 36 quoted lines
> Junio C Hamano <gitster@pobox.com> writes:
> 
> -- >8 --
> From: Junio C Hamano <gitster@pobox.com>
> Date: Sun, 12 Dec 2010 23:27:21 -0800
> Subject: [PATCH] Rename po/pt_BR.po to po/pt_br.po
> 
> The "msgfmt --tcl pt_BR.po" (at least on my box, GNU gettext 0.17) command
> generates pt_BR.msg, i.e. the country part gets downcased.  The resulting
> runtime (i.e. Tcl i18n) happily reads from pt_br.msg when run with the
> runtime locale set with LANG=pt_BR and/or LC_ALL=pt_BR so it seems to be
> the expected behaviour.
> 
> However, we seem to expect that the resulting file to be named pt_BR.msg,
> and try to generate and install it.
> 
> Currently our Makefile uses $(wildcard po/*.po) to grab the source PO
> files, expects them to produce $(subst .po,.msg,$(ALL_POFILES)), and its
> dependency rule is set to use "%.msg : %.po" pattern, all of which need
> to be adjusted with downcasing from po to msg files; the poor-man's msgfmt
> script also needs to learn the same downcasing.
> 
> Compared to that, renaming the input file to use lowercase countryname
> throughout the toolchain seems to be a lot cleaner solution to this
> glitch.
> 
> Signed-off-by: Junio C Hamano <gitster@pobox.com>
> ---
>  po/{pt_BR.po => pt_br.po} |    0
>  1 files changed, 0 insertions(+), 0 deletions(-)
>  rename po/{pt_BR.po => pt_br.po} (100%)
> 
> diff --git a/po/pt_BR.po b/po/pt_br.po
> similarity index 100%
> rename from po/pt_BR.po
> rename to po/pt_br.po

Sorry about the glitch. The renaming seems like the best idea, since all the other .po files have lowercase names. I was hoping to hear Alexandre Erwin Ittner's opinion, though.

If I apply this patch in my repo, is that going to cause problems in yours? Or, since the commit that adds this file is the head commit, I could just rewind it and reapply with the lowercase name. Do you see problems with that?

Paul.
Junio C Hamano· Dec 13, 2010, 21:45 UTC · re: Paul Mackerras · lore

Re: Please pull gitk.git master branch

Paul Mackerras <paulus@samba.org> writes:
> Sorry about the glitch.  The renaming seems like the best idea, since
> all the other .po files have lowercase names.

Usually people spell language in lower and region in upper, e.g. ja_JP, so to eyes trained in i18n renaming doesn't look very nice. I just wanted to know that Tcl folks do not care about that ;-)

> If I apply this patch in my repo, is that going to cause problems in
> yours?  Or, since the commit that adds this file is the head commit, I
> could just rewind it and reapply with the lowercase name.  Do you see
> problems with that?

Either way is fine by me, as the merge I pushed out last night is only on 'pu' that is advertised as unstable.

Thanks.
Paul Mackerras· Dec 14, 2010, 09:07 UTC · re: Junio C Hamano · lore

Re: Please pull gitk.git master branch

On Mon, Dec 13, 2010 at 01:45:14PM -0800, Junio C Hamano wrote:
Show 8 quoted lines
> Paul Mackerras <paulus@samba.org> writes:
> > If I apply this patch in my repo, is that going to cause problems in
> > yours?  Or, since the commit that adds this file is the head commit, I
> > could just rewind it and reapply with the lowercase name.  Do you see
> > problems with that?
> 
> Either way is fine by me, as the merge I pushed out last night is only on
> 'pu' that is advertised as unstable.

OK, I re-did the top commit using the lowercase name. Please do a git pull -f to get the new version of that commit.

Thanks, Paul.

Junio C Hamano· Dec 14, 2010, 17:09 UTC · re: Paul Mackerras · lore

Re: Please pull gitk.git master branch

Paul Mackerras <paulus@samba.org> writes:
> OK, I re-did the top commit using the lowercase name.  Please do a
> git pull -f to get the new version of that commit.
Thanks.  Will do.

← back to recent threads