{"thread":{"id":"26025","subject":"Please pull gitk.git master branch","startedAt":"2010-12-12T06:31:35Z","lastAt":"2010-12-14T17:09:47Z","messageCount":11,"participants":["Paul Mackerras","Junio C Hamano","Sverre Rabbelier","Andreas Ericsson","Andreas Schwab"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"157879","messageId":"20101212063135.GA7677@brick.ozlabs.ibm.com","threadId":"26025","inReplyTo":null,"subject":"Please pull gitk.git master branch","fromName":"Paul Mackerras","fromEmail":"paulus@samba.org","sentAt":"2010-12-12T06:31:35Z","receivedAt":"2010-12-12T06:31:35Z","isPatch":false,"sender":{"key":"paulus@samba.org","avatar":"https://avatars.githubusercontent.com/u/1606439?v=4"},"body":"Junio,\n\nPlease do a pull from\n\ngit://git.kernel.org/pub/scm/gitk/gitk.git\n\nto get the commits listed below.\n\nThanks,\nPaul.\n\n gitk        |   81 +++-\n po/pt_BR.po | 1277 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++\n po/sv.po    |  601 ++++++++++++++--------------\n 3 files changed, 1654 insertions(+), 305 deletions(-)\n create mode 100644 po/pt_BR.po\n\nAlexandre Erwin Ittner (1):\n      gitk: Add Brazilian Portuguese (pt-BR) translation\n\nKirill Smelkov (1):\n      gitk: Show notes by default (like git log does)\n\nPeter Krefting (1):\n      gitk: Update Swedish translation (290t)\n\nStefan Haller (2):\n      gitk: Prevent the text pane from becoming editable\n      gitk: Make text selectable on Mac\n\nThomas Rast (1):\n      gitk: Add the equivalent of diff --color-words\n"},{"id":"157902","messageId":"7vwrne8tow.fsf@alter.siamese.dyndns.org","threadId":"26025","inReplyTo":"20101212063135.GA7677@brick.ozlabs.ibm.com","subject":"Re: Please pull gitk.git master branch","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2010-12-12T23:20:15Z","receivedAt":"2010-12-12T23:20:15Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Thanks, pulled (not yet pushed out).\n"},{"id":"157915","messageId":"7v7hfe74ea.fsf@alter.siamese.dyndns.org","threadId":"26025","inReplyTo":"7vwrne8tow.fsf@alter.siamese.dyndns.org","subject":"Re: Please pull gitk.git master branch","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2010-12-13T03:11:57Z","receivedAt":"2010-12-13T03:11:57Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Junio C Hamano <gitster@pobox.com> writes:\n\n> Thanks, pulled (not yet pushed out).\n\nYikes.\n\nPaul, has this ever been install-tested before you accepted the \"pt-BR\"\npatch to your repository?\n\n\"msgfmt --tcl\" produces po/pt_br.msg for me, but the Makefile wants to\ninstall po/pt_BR.msg and fails.  Perhaps the poor-man's po2msg.sh does not\nhave this glitch and produces po/pt_BR.msg, but I don't think that is an\nexcuse for not checking with both that script and the real msgfmt before\nthe change gets this far.\n\nUsing the -o option on the msgfmt command line to force the command to\ngenerate pt_BR.msg fails with:\n\n    msgfmt: --tcl and --output-file are mutually exclusive\n\nCombined with this and the fact that msgfmt produces po/pt_br.msg out of\nthe input po/pt_BR.po makes me suspect that Tcl runtime enviornment does\nnot actually expect pt_BR.msg but want to see the country part downcased.\nIn which case we may need to fix po2msg.sh to match that behaviour.\n\nAn workaround would be to rename po/pt_BR.po to po/pt_br.po but I don't\nknow if there are unexpected side effects if we did that.\n\nI'd like to see this glitch sorted out before I push out the result of the\nmerge, so it is likely there won't be a pushout tonight.  We need to know:\n\n * Is this \"downcase the country part for --tcl\" a bug in the particular\n   version of msgfmt I happen to have (it is 0.17 from GNU gettext on\n   Debian), or is it the filename convention expected by the Tcl i18n\n   runtime environment to have both language and country in lowercase?\n\n * What is the recommended best practice in Tcl i18n community for naming\n   lang_COUNTRY.po file?  Do people typically spell the COUNTRY in\n   uppercase and let \"msgfmt --tcl\" downcase, and deal with the filename\n   case issues in the Makefile themselves?  This feels yucky, as it means\n   that we cannot use '%.msg : %.po' dependency pattern, but need to list\n   the dependencies by hand.  Or do they spell country part in lowercase\n   to avoid this whole issue?\n\nMy _preferred_ outcome is to see that naming the input \"po/pt_br.po\" and\nusing the output \"po/pt_br.msg\" is the BCP, but I'd like somebody to find\nout what the accepted practice would be in the Tcl land first.\n"},{"id":"157927","messageId":"7vbp4q5ddo.fsf@alter.siamese.dyndns.org","threadId":"26025","inReplyTo":"7v7hfe74ea.fsf@alter.siamese.dyndns.org","subject":"Re: Please pull gitk.git master branch","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2010-12-13T07:40:51Z","receivedAt":"2010-12-13T07:40:51Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Junio C Hamano <gitster@pobox.com> writes:\n\n> My _preferred_ outcome is to see that naming the input \"po/pt_br.po\" and\n> using the output \"po/pt_br.msg\" is the BCP, but I'd like somebody to find\n> out what the accepted practice would be in the Tcl land first.\n\nI still don't know what the BCP is in the Tcl community (didn't have time\nto check, dealing with other topics), but I'll tentatively apply this on\ntop of queue Alexandre's patch and merge the result in 'pu'.\n\n-- >8 --\nFrom: Junio C Hamano <gitster@pobox.com>\nDate: Sun, 12 Dec 2010 23:27:21 -0800\nSubject: [PATCH] Rename po/pt_BR.po to po/pt_br.po\n\nThe \"msgfmt --tcl pt_BR.po\" (at least on my box, GNU gettext 0.17) command\ngenerates pt_BR.msg, i.e. the country part gets downcased.  The resulting\nruntime (i.e. Tcl i18n) happily reads from pt_br.msg when run with the\nruntime locale set with LANG=pt_BR and/or LC_ALL=pt_BR so it seems to be\nthe expected behaviour.\n\nHowever, we seem to expect that the resulting file to be named pt_BR.msg,\nand try to generate and install it.\n\nCurrently our Makefile uses $(wildcard po/*.po) to grab the source PO\nfiles, expects them to produce $(subst .po,.msg,$(ALL_POFILES)), and its\ndependency rule is set to use \"%.msg : %.po\" pattern, all of which need\nto be adjusted with downcasing from po to msg files; the poor-man's msgfmt\nscript also needs to learn the same downcasing.\n\nCompared to that, renaming the input file to use lowercase countryname\nthroughout the toolchain seems to be a lot cleaner solution to this\nglitch.\n\nSigned-off-by: Junio C Hamano <gitster@pobox.com>\n---\n po/{pt_BR.po => pt_br.po} |    0\n 1 files changed, 0 insertions(+), 0 deletions(-)\n rename po/{pt_BR.po => pt_br.po} (100%)\n\ndiff --git a/po/pt_BR.po b/po/pt_br.po\nsimilarity index 100%\nrename from po/pt_BR.po\nrename to po/pt_br.po\n"},{"id":"157931","messageId":"AANLkTinPqDbvdG9r4UFcKq9BJSw4by4_hJdEN+0oUaJZ@mail.gmail.com","threadId":"26025","inReplyTo":"7vbp4q5ddo.fsf@alter.siamese.dyndns.org","subject":"Re: Please pull gitk.git master branch","fromName":"Sverre Rabbelier","fromEmail":"srabbelier@gmail.com","sentAt":"2010-12-13T08:36:31Z","receivedAt":"2010-12-13T08:36:31Z","isPatch":false,"sender":{"key":"srabbelier@gmail.com","avatar":"https://avatars.githubusercontent.com/u/3098?v=4"},"body":"Heya,\n\nOn Mon, Dec 13, 2010 at 08:40, Junio C Hamano <gitster@pobox.com> wrote:\n>> My _preferred_ outcome is to see that naming the input \"po/pt_br.po\" and\n>> using the output \"po/pt_br.msg\" is the BCP, but I'd like somebody to find\n>> out what the accepted practice would be in the Tcl land first.\n>\n> I still don't know what the BCP is in the Tcl community (didn't have time\n> to check, dealing with other topics), but I'll tentatively apply this on\n> top of queue Alexandre's patch and merge the result in 'pu'.\n\nPardon my ignorance, what is BCP? None of the definitions I could find\nseemed likely.\n\n-- \nCheers,\n\nSverre Rabbelier\n"},{"id":"157933","messageId":"4D05E68C.70306@op5.se","threadId":"26025","inReplyTo":"AANLkTinPqDbvdG9r4UFcKq9BJSw4by4_hJdEN+0oUaJZ@mail.gmail.com","subject":"Re: Please pull gitk.git master branch","fromName":"Andreas Ericsson","fromEmail":"ae@op5.se","sentAt":"2010-12-13T09:25:32Z","receivedAt":"2010-12-13T09:25:32Z","isPatch":false,"sender":{"key":"ae@op5.se","avatar":"https://gravatar.com/avatar/426e89595c75a8f5252dd0c989e5fabe5bcac616e68557427ad9aef6b0ca342a?d=mp&s=160"},"body":"On 12/13/2010 09:36 AM, Sverre Rabbelier wrote:\n> Heya,\n> \n> On Mon, Dec 13, 2010 at 08:40, Junio C Hamano<gitster@pobox.com>  wrote:\n>>> My _preferred_ outcome is to see that naming the input \"po/pt_br.po\" and\n>>> using the output \"po/pt_br.msg\" is the BCP, but I'd like somebody to find\n>>> out what the accepted practice would be in the Tcl land first.\n>>\n>> I still don't know what the BCP is in the Tcl community (didn't have time\n>> to check, dealing with other topics), but I'll tentatively apply this on\n>> top of queue Alexandre's patch and merge the result in 'pu'.\n> \n> Pardon my ignorance, what is BCP? None of the definitions I could find\n> seemed likely.\n> \n\nBest Coding Practice.\n\n-- \nAndreas Ericsson                   andreas.ericsson@op5.se\nOP5 AB                             www.op5.se\nTel: +46 8-230225                  Fax: +46 8-230231\n\nConsidering the successes of the wars on alcohol, poverty, drugs and\nterror, I think we should give some serious thought to declaring war\non peace.\n"},{"id":"157994","messageId":"m2mxo91mct.fsf@igel.home","threadId":"26025","inReplyTo":"AANLkTinPqDbvdG9r4UFcKq9BJSw4by4_hJdEN+0oUaJZ@mail.gmail.com","subject":"Re: Please pull gitk.git master branch","fromName":"Andreas Schwab","fromEmail":"schwab@linux-m68k.org","sentAt":"2010-12-13T19:52:50Z","receivedAt":"2010-12-13T19:52:50Z","isPatch":false,"sender":{"key":"schwab@linux-m68k.org","avatar":"https://avatars.githubusercontent.com/u/2175493?v=4"},"body":"Sverre Rabbelier <srabbelier@gmail.com> writes:\n\n> Pardon my ignorance, what is BCP? None of the definitions I could find\n> seemed likely.\n\nhttp://en.wikipedia.org/wiki/Best_Current_Practice\n\nAndreas.\n\n-- \nAndreas Schwab, schwab@linux-m68k.org\nGPG Key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276 4ED5\n\"And now for something completely different.\"\n"},{"id":"157998","messageId":"20101213210317.GA10027@brick.ozlabs.ibm.com","threadId":"26025","inReplyTo":"7vbp4q5ddo.fsf@alter.siamese.dyndns.org","subject":"Re: Please pull gitk.git master branch","fromName":"Paul Mackerras","fromEmail":"paulus@samba.org","sentAt":"2010-12-13T21:03:17Z","receivedAt":"2010-12-13T21:03:17Z","isPatch":false,"sender":{"key":"paulus@samba.org","avatar":"https://avatars.githubusercontent.com/u/1606439?v=4"},"body":"On Sun, Dec 12, 2010 at 11:40:51PM -0800, Junio C Hamano wrote:\n> Junio C Hamano <gitster@pobox.com> writes:\n> \n> -- >8 --\n> From: Junio C Hamano <gitster@pobox.com>\n> Date: Sun, 12 Dec 2010 23:27:21 -0800\n> Subject: [PATCH] Rename po/pt_BR.po to po/pt_br.po\n> \n> The \"msgfmt --tcl pt_BR.po\" (at least on my box, GNU gettext 0.17) command\n> generates pt_BR.msg, i.e. the country part gets downcased.  The resulting\n> runtime (i.e. Tcl i18n) happily reads from pt_br.msg when run with the\n> runtime locale set with LANG=pt_BR and/or LC_ALL=pt_BR so it seems to be\n> the expected behaviour.\n> \n> However, we seem to expect that the resulting file to be named pt_BR.msg,\n> and try to generate and install it.\n> \n> Currently our Makefile uses $(wildcard po/*.po) to grab the source PO\n> files, expects them to produce $(subst .po,.msg,$(ALL_POFILES)), and its\n> dependency rule is set to use \"%.msg : %.po\" pattern, all of which need\n> to be adjusted with downcasing from po to msg files; the poor-man's msgfmt\n> script also needs to learn the same downcasing.\n> \n> Compared to that, renaming the input file to use lowercase countryname\n> throughout the toolchain seems to be a lot cleaner solution to this\n> glitch.\n> \n> Signed-off-by: Junio C Hamano <gitster@pobox.com>\n> ---\n>  po/{pt_BR.po => pt_br.po} |    0\n>  1 files changed, 0 insertions(+), 0 deletions(-)\n>  rename po/{pt_BR.po => pt_br.po} (100%)\n> \n> diff --git a/po/pt_BR.po b/po/pt_br.po\n> similarity index 100%\n> rename from po/pt_BR.po\n> rename to po/pt_br.po\n\nSorry about the glitch.  The renaming seems like the best idea, since\nall the other .po files have lowercase names.  I was hoping to hear\nAlexandre Erwin Ittner's opinion, though.\n\nIf I apply this patch in my repo, is that going to cause problems in\nyours?  Or, since the commit that adds this file is the head commit, I\ncould just rewind it and reapply with the lowercase name.  Do you see\nproblems with that?\n\nPaul.\n"},{"id":"158001","messageId":"7vy67txs7p.fsf@alter.siamese.dyndns.org","threadId":"26025","inReplyTo":"20101213210317.GA10027@brick.ozlabs.ibm.com","subject":"Re: Please pull gitk.git master branch","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2010-12-13T21:45:14Z","receivedAt":"2010-12-13T21:45:14Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Paul Mackerras <paulus@samba.org> writes:\n\n> Sorry about the glitch.  The renaming seems like the best idea, since\n> all the other .po files have lowercase names.\n\nUsually people spell language in lower and region in upper, e.g. ja_JP, so\nto eyes trained in i18n renaming doesn't look very nice.  I just wanted to\nknow that Tcl folks do not care about that ;-)\n\n> If I apply this patch in my repo, is that going to cause problems in\n> yours?  Or, since the commit that adds this file is the head commit, I\n> could just rewind it and reapply with the lowercase name.  Do you see\n> problems with that?\n\nEither way is fine by me, as the merge I pushed out last night is only on\n'pu' that is advertised as unstable.\n\nThanks.\n"},{"id":"158039","messageId":"20101214090707.GA11890@brick.ozlabs.ibm.com","threadId":"26025","inReplyTo":"7vy67txs7p.fsf@alter.siamese.dyndns.org","subject":"Re: Please pull gitk.git master branch","fromName":"Paul Mackerras","fromEmail":"paulus@samba.org","sentAt":"2010-12-14T09:07:07Z","receivedAt":"2010-12-14T09:07:07Z","isPatch":false,"sender":{"key":"paulus@samba.org","avatar":"https://avatars.githubusercontent.com/u/1606439?v=4"},"body":"On Mon, Dec 13, 2010 at 01:45:14PM -0800, Junio C Hamano wrote:\n> Paul Mackerras <paulus@samba.org> writes:\n> > If I apply this patch in my repo, is that going to cause problems in\n> > yours?  Or, since the commit that adds this file is the head commit, I\n> > could just rewind it and reapply with the lowercase name.  Do you see\n> > problems with that?\n> \n> Either way is fine by me, as the merge I pushed out last night is only on\n> 'pu' that is advertised as unstable.\n\nOK, I re-did the top commit using the lowercase name.  Please do a\ngit pull -f to get the new version of that commit.\n\nThanks,\nPaul.\n"},{"id":"158061","messageId":"7voc8ouvqc.fsf@alter.siamese.dyndns.org","threadId":"26025","inReplyTo":"20101214090707.GA11890@brick.ozlabs.ibm.com","subject":"Re: Please pull gitk.git master branch","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2010-12-14T17:09:47Z","receivedAt":"2010-12-14T17:09:47Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Paul Mackerras <paulus@samba.org> writes:\n\n> OK, I re-did the top commit using the lowercase name.  Please do a\n> git pull -f to get the new version of that commit.\n\nThanks.  Will do.\n"}]}