git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: Please pull gitk.git master branch

From
Junio C Hamano <gitster@pobox.com>
Date
Dec 13, 2010, 03:11 UTC
Message-ID
<7v7hfe74ea.fsf@alter.siamese.dyndns.org>
In-Reply-To
<7vwrne8tow.fsf@alter.siamese.dyndns.org>
Junio C Hamano <gitster@pobox.com> writes:
> Thanks, pulled (not yet pushed out).
Yikes.

Paul, has this ever been install-tested before you accepted the "pt-BR" patch to your repository?

"msgfmt --tcl" produces po/pt_br.msg for me, but the Makefile wants to install po/pt_BR.msg and fails. Perhaps the poor-man's po2msg.sh does not have this glitch and produces po/pt_BR.msg, but I don't think that is an excuse for not checking with both that script and the real msgfmt before the change gets this far.

Using the -o option on the msgfmt command line to force the command to generate pt_BR.msg fails with:

    msgfmt: --tcl and --output-file are mutually exclusive

Combined with this and the fact that msgfmt produces po/pt_br.msg out of the input po/pt_BR.po makes me suspect that Tcl runtime enviornment does not actually expect pt_BR.msg but want to see the country part downcased. In which case we may need to fix po2msg.sh to match that behaviour.

An workaround would be to rename po/pt_BR.po to po/pt_br.po but I don't know if there are unexpected side effects if we did that.

I'd like to see this glitch sorted out before I push out the result of the merge, so it is likely there won't be a pushout tonight. We need to know:

 * Is this "downcase the country part for --tcl" a bug in the particular
   version of msgfmt I happen to have (it is 0.17 from GNU gettext on
   Debian), or is it the filename convention expected by the Tcl i18n
   runtime environment to have both language and country in lowercase?
 * What is the recommended best practice in Tcl i18n community for naming
   lang_COUNTRY.po file?  Do people typically spell the COUNTRY in
   uppercase and let "msgfmt --tcl" downcase, and deal with the filename
   case issues in the Makefile themselves?  This feels yucky, as it means
   that we cannot use '%.msg : %.po' dependency pattern, but need to list
   the dependencies by hand.  Or do they spell country part in lowercase
   to avoid this whole issue?

My _preferred_ outcome is to see that naming the input "po/pt_br.po" and using the output "po/pt_br.msg" is the BCP, but I'd like somebody to find out what the accepted practice would be in the Tcl land first.

Previous: Junio C HamanoNext: Junio C Hamano
Message 3 of 11 in “Please pull gitk.git master branch”
  1. Paul MackerrasDec 12, 2010
  2. Junio C HamanoDec 12, 2010
  3. Junio C HamanoDec 13, 2010
  4. Junio C HamanoDec 13, 2010
  5. Sverre RabbelierDec 13, 2010
  6. Andreas EricssonDec 13, 2010
  7. Andreas SchwabDec 13, 2010
  8. Paul MackerrasDec 13, 2010
  9. Junio C HamanoDec 13, 2010
  10. Paul MackerrasDec 14, 2010
  11. Junio C HamanoDec 14, 2010

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.