git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 1/5] string-list: fix sign compare warnings

From
Junio C Hamano <gitster@pobox.com>
Date
Apr 22, 2025, 21:02 UTC
Message-ID
<xmqqy0vr3o6d.fsf@gitster.g>
In-Reply-To
<aAett8cJuDJ_FSdw@ArchLinux>
shejialuo <shejialuo@gmail.com> writes:
> However, for "string-list.c::add_entry" function, we compare the `index`
> of the `int` type with the `list->nr` of unsigned type. It seems that
> we could just simply convert the type of `index` from `int` to
> `size_t`. But actually this is a correct behavior.
Sorry, but I am lost by the last sentence.

"this" that is a correct behavior refers to...? That the incoming parameter insert_at and the local variable index are both of signed integer?

> We would set the `index` value by checking whether `insert_at` is -1.
> If not, we would set `index` to be `insert_at`, otherwise we would use
> "get_entry_index` to find the inserted position.

To rephrase the above (simply because the above is literal English translation from what C says), the caller either can pass -1 to mean "find an appropriate location in the list to keep it sorted", or an index into the list->items[] array to specify exactly where the item should be inserted.

Naturally, insert_at must be either -1 (auto), or between 0 (i.e. the candidate is smaller than anything in the list) and list->nr (i.e. the candidate is larger than everything in the list) inclusive. Any other value is invalid. I think that is a more appropriate thing to say than ...

> What if the caller passes a negative value except "-1", the compiler
> would convert the `index` to be a positive value which would make the
> `if` statement be false to avoid moving array. However, we would
> definitely encounter trouble when setting the inserted item.

... this paragraph. Not moving is _not_ avoiding problem, so it is immaterial. The lack of valid range check before using the index is.

Show 6 quoted lines
> And we only call "add_entry" in "string_list_insert" function, and we
> simply pass "-1" for "insert_at" parameter. So, we never use this
> parameter to insert element in a user specified position. Let's delete
> this parameter. If there is any requirement later, we may use a better
> way to do this. And then we could safely convert the index to be
> `size_t` when comparing.

Good. As we only use the "auto" setting with this code now, as long as get_entry_index() returns a value between 0 and list->nr, the lack of such range checking in the original code no longer is an issue.

Having said that, in the longer run, get_entry_index() would want to return size_t simply because it is returning a value between 0 and list->nr, whose type is size_t. left/mid/right variables also need to become size_t and the loop initialization may have to be tweaked (since the current code strangely starts left with -1 which would never be the index into the array), but fixing that should probably make the loop easier to read, which is a bonus.

And add_entry(), since it needs to do the usual -1-pos dance to indicate where things would have been returned, would return ssize_t---or better yet, it can just turned into returning size_t with an extra out parameter (just like the exact_match out parameter get_entry_index() has) to indicate if we already had the same item in the list already. It is perfectly fine to leave it outside the scope of this series, but if you are tweaking all the callers of add_entry() anyway in this step, you may want to bite the bullet and just go all the way.

Thanks.
Previous: shejialuoNext: shejialuo
Message 3 of 52 in “enhance "string_list" code and test”
  1. 0/5 enhance "string_list" code and testshejialuo, Apr 22, 2025
  2. 1/5 string-list: fix sign compare warningsshejialuo, Apr 22, 2025
  3. Junio C HamanoApr 22, 2025
  4. shejialuoApr 24, 2025
  5. 2/5 u-string-list: move "test_split" into "u-string-list.c"shejialuo, Apr 22, 2025
  6. Junio C HamanoApr 22, 2025
  7. shejialuoApr 24, 2025
  8. Patrick SteinhardtApr 23, 2025
  9. shejialuoApr 24, 2025
  10. 3/5 u-string-list: move "test_split_in_place" to "u-string-list.c"shejialuo, Apr 22, 2025
  11. Patrick SteinhardtApr 23, 2025
  12. 4/5 u-string-list: move "filter string" test to "u-string-list.c"shejialuo, Apr 22, 2025
  13. 5/5 u-string-list: move "remove duplicates" test to "u-string-list.c"shejialuo, Apr 22, 2025
  14. Patrick SteinhardtApr 23, 2025
  15. shejialuoApr 24, 2025
  16. 0/8 enhance "string_list" code and testshejialuo, May 18, 2025
  17. 1/8 string-list: fix sign compare warnings for loop iteratorshejialuo, May 18, 2025
  18. Patrick SteinhardtMay 19, 2025
  19. shejialuoMay 26, 2025
  20. 2/8 string-list: remove unused "insert_at" parameter from add_entryshejialuo, May 18, 2025
  21. Patrick SteinhardtMay 19, 2025
  22. shejialuoMay 26, 2025
  23. Jeff KingMay 19, 2025
  24. shejialuoMay 26, 2025
  25. Patrick SteinhardtMay 26, 2025
  26. 3/8 string-list: return index directly when inserting an existing elementshejialuo, May 18, 2025
  27. Patrick SteinhardtMay 19, 2025
  28. shejialuoMay 26, 2025
  29. Jeff KingMay 19, 2025
  30. shejialuoMay 26, 2025
  31. 4/8 string-list: enable sign compare warnings checkshejialuo, May 18, 2025
  32. Patrick SteinhardtMay 19, 2025
  33. shejialuoMay 26, 2025
  34. 5/8 u-string-list: move "test_split" into "u-string-list.c"shejialuo, May 18, 2025
  35. Patrick SteinhardtMay 19, 2025
  36. 6/8 u-string-list: move "test_split_in_place" to "u-string-list.c"shejialuo, May 18, 2025
  37. 7/8 u-string-list: move "filter string" test to "u-string-list.c"shejialuo, May 18, 2025
  38. Patrick SteinhardtMay 19, 2025
  39. shejialuoMay 26, 2025
  40. 8/8 u-string-list: move "remove duplicates" test to "u-string-list.c"shejialuo, May 18, 2025
  41. Patrick SteinhardtMay 19, 2025
  42. 0/8 enhance "string_list" code and testshejialuo, Jun 29, 2025
  43. 1/8 string-list: fix sign compare warnings for loop iteratorshejialuo, Jun 29, 2025
  44. 2/8 string-list: remove unused "insert_at" parameter from add_entryshejialuo, Jun 29, 2025
  45. 3/8 string-list: return index directly when inserting an existing elementshejialuo, Jun 29, 2025
  46. 4/8 string-list: enable sign compare warnings checkshejialuo, Jun 29, 2025
  47. 5/8 u-string-list: move "test_split" into "u-string-list.c"shejialuo, Jun 29, 2025
  48. 6/8 u-string-list: move "test_split_in_place" to "u-string-list.c"shejialuo, Jun 29, 2025
  49. 7/8 u-string-list: move "filter string" test to "u-string-list.c"shejialuo, Jun 29, 2025
  50. 8/8 u-string-list: move "remove duplicates" test to "u-string-list.c"shejialuo, Jun 29, 2025
  51. Patrick SteinhardtJul 4, 2025
  52. Junio C HamanoJul 7, 2025

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.