git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 2/5] u-string-list: move "test_split" into "u-string-list.c"

From
Junio C Hamano <gitster@pobox.com>
Date
Apr 22, 2025, 21:27 UTC
Message-ID
<xmqqr01j3n15.fsf@gitster.g>
In-Reply-To
<aAetv8l8jrxvEywB@ArchLinux>
shejialuo <shejialuo@gmail.com> writes:
Show 19 quoted lines
> We rely on "test-tool string-list" command to test the functionality of
> the "string-list". However, as we have introduced clar test framework,
> we'd better move the shell script into C program to improve speed and
> readability.
>
> Create a new file "u-string-list.c" under "t/unit-tests", then update
> the Makefile and "meson.build" to build the file. And let's first move
> "test_split" into unit test and gradually convert the shell script into
> C program.
>
> In order to create `string_list` easily by simply specifying strings in
> the function call, create "t_vcreate_string_list_dup" and
> "t_create_string_list_dup" functions to do above.
>
> Then port the shell script tests to C program and remove unused
> "test-tool" code and tests.
>
> Signed-off-by: shejialuo <shejialuo@gmail.com>
> ---

This is the most interesting in the u-string-list patches, as it adds not just a moved test but adds supporting functions that are shared with test functions added in later steps.

Show 19 quoted lines
> diff --git a/t/unit-tests/u-string-list.c b/t/unit-tests/u-string-list.c
> new file mode 100644
> index 0000000000..0c148684ea
> --- /dev/null
> +++ b/t/unit-tests/u-string-list.c
> @@ -0,0 +1,86 @@
> +#include "unit-test.h"
> +#include "string-list.h"
> +
> +static void t_check_string_list(struct string_list *list,
> +				struct string_list *expected_strings)
> +{
> +	size_t expect_len = expected_strings->nr;
> +	cl_assert_equal_i(list->nr, expect_len);
> +	cl_assert(list->nr <= list->alloc);
> +	for (size_t i = 0; i < expect_len; i++)
> +		cl_assert_equal_s(list->items[i].string,
> +				  expected_strings->items[i].string);
> +}

Perhaps call it "string_list_equal()" or something? "check" is a convenient name that can mean different kind of validation that is not limited to "is the actual answer identical to the expected one?"

Wouldn't it be cleaner to read if you wrote it without an extra variable expect_len? The compiler would notice repeated reference of expected_strings->nr and optimize them away anyway, I would imagine.

Show 7 quoted lines
> +static void t_string_list_clear(struct string_list *list, int free_util)
> +{
> +	string_list_clear(list, free_util);
> +	cl_assert_equal_p(list->items, NULL);
> +	cl_assert_equal_i(list->nr, 0);
> +	cl_assert_equal_i(list->alloc, 0);
> +}

Validating the result of clearing a list may be a good thing to do at least once in the test suite, but this is called from many places in other tests. Conceptually it feels kludgy to call this from other places where they should all just call string_list_clear(), like ...

Show 8 quoted lines
> +static void t_vcreate_string_list_dup(struct string_list *list,
> +				      int free_util, va_list ap)
> +{
> +	const char *arg;
> +
> +	cl_assert(list->strdup_strings);
> +
> +	t_string_list_clear(list, free_util);
... this place.
> +	while ((arg = va_arg(ap, const char *)))
> +		string_list_append(list, arg);
> +}

To put it differently, you could be calling t_string_list_append() in this loop, which would

 - remember list->nr
 - call string_list_append()
 - cl_assert_equal() to ensure that list->nr is one larger than
   the value we remembered upon entry to the function.

which is not wrong per-se, but hopefully you'd agree that it is overkill. t_stirng_list_clear() is overkill in the same way.

Show 11 quoted lines
> +void test_string_list__split(void)
> +{
> +	struct string_list expected_strings = STRING_LIST_INIT_DUP;
> +
> +	t_create_string_list_dup(&expected_strings, 0, "foo", "bar", "baz", NULL);
> +...
> +	t_create_string_list_dup(&expected_strings, 0, "", "", NULL);
> +	t_string_list_split(":", ':', -1, &expected_strings);
> +
> +	t_string_list_clear(&expected_strings, 0);
> +}

This is a good place to call t_string_list_clear(), just once in this script. All other callers are conceptually simpler to call string_list_clear(), as the point at their callsites is to clear after themselves, not about testing string_list_clear() works correctly.

Thanks.
Previous: shejialuoNext: shejialuo
Message 6 of 52 in “enhance "string_list" code and test”
  1. 0/5 enhance "string_list" code and testshejialuo, Apr 22, 2025
  2. 1/5 string-list: fix sign compare warningsshejialuo, Apr 22, 2025
  3. Junio C HamanoApr 22, 2025
  4. shejialuoApr 24, 2025
  5. 2/5 u-string-list: move "test_split" into "u-string-list.c"shejialuo, Apr 22, 2025
  6. Junio C HamanoApr 22, 2025
  7. shejialuoApr 24, 2025
  8. Patrick SteinhardtApr 23, 2025
  9. shejialuoApr 24, 2025
  10. 3/5 u-string-list: move "test_split_in_place" to "u-string-list.c"shejialuo, Apr 22, 2025
  11. Patrick SteinhardtApr 23, 2025
  12. 4/5 u-string-list: move "filter string" test to "u-string-list.c"shejialuo, Apr 22, 2025
  13. 5/5 u-string-list: move "remove duplicates" test to "u-string-list.c"shejialuo, Apr 22, 2025
  14. Patrick SteinhardtApr 23, 2025
  15. shejialuoApr 24, 2025
  16. 0/8 enhance "string_list" code and testshejialuo, May 18, 2025
  17. 1/8 string-list: fix sign compare warnings for loop iteratorshejialuo, May 18, 2025
  18. Patrick SteinhardtMay 19, 2025
  19. shejialuoMay 26, 2025
  20. 2/8 string-list: remove unused "insert_at" parameter from add_entryshejialuo, May 18, 2025
  21. Patrick SteinhardtMay 19, 2025
  22. shejialuoMay 26, 2025
  23. Jeff KingMay 19, 2025
  24. shejialuoMay 26, 2025
  25. Patrick SteinhardtMay 26, 2025
  26. 3/8 string-list: return index directly when inserting an existing elementshejialuo, May 18, 2025
  27. Patrick SteinhardtMay 19, 2025
  28. shejialuoMay 26, 2025
  29. Jeff KingMay 19, 2025
  30. shejialuoMay 26, 2025
  31. 4/8 string-list: enable sign compare warnings checkshejialuo, May 18, 2025
  32. Patrick SteinhardtMay 19, 2025
  33. shejialuoMay 26, 2025
  34. 5/8 u-string-list: move "test_split" into "u-string-list.c"shejialuo, May 18, 2025
  35. Patrick SteinhardtMay 19, 2025
  36. 6/8 u-string-list: move "test_split_in_place" to "u-string-list.c"shejialuo, May 18, 2025
  37. 7/8 u-string-list: move "filter string" test to "u-string-list.c"shejialuo, May 18, 2025
  38. Patrick SteinhardtMay 19, 2025
  39. shejialuoMay 26, 2025
  40. 8/8 u-string-list: move "remove duplicates" test to "u-string-list.c"shejialuo, May 18, 2025
  41. Patrick SteinhardtMay 19, 2025
  42. 0/8 enhance "string_list" code and testshejialuo, Jun 29, 2025
  43. 1/8 string-list: fix sign compare warnings for loop iteratorshejialuo, Jun 29, 2025
  44. 2/8 string-list: remove unused "insert_at" parameter from add_entryshejialuo, Jun 29, 2025
  45. 3/8 string-list: return index directly when inserting an existing elementshejialuo, Jun 29, 2025
  46. 4/8 string-list: enable sign compare warnings checkshejialuo, Jun 29, 2025
  47. 5/8 u-string-list: move "test_split" into "u-string-list.c"shejialuo, Jun 29, 2025
  48. 6/8 u-string-list: move "test_split_in_place" to "u-string-list.c"shejialuo, Jun 29, 2025
  49. 7/8 u-string-list: move "filter string" test to "u-string-list.c"shejialuo, Jun 29, 2025
  50. 8/8 u-string-list: move "remove duplicates" test to "u-string-list.c"shejialuo, Jun 29, 2025
  51. Patrick SteinhardtJul 4, 2025
  52. Junio C HamanoJul 7, 2025

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.